Find the answer to your Linux question:
Results 1 to 8 of 8
I wanted to upgrade to 2.6.20.2 (cause it would be cool ), and so I rehersed with recompiling my CD installation 2.4.33.3 kernel without modifications. I read the README and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    21

    When I recompile the kernel there is no sound!


    I wanted to upgrade to 2.6.20.2 (cause it would be cool ), and so I rehersed with recompiling my CD installation 2.4.33.3 kernel without modifications. I read the README and followed the instructions:

    changed the extraversion in Makefile

    cd /root/linux
    make mrproper
    cp /boot/config ./.config
    make oldconfig
    make bzImage
    make modules
    make install
    make modules_install
    mv /vmlinuz /boot/vmlinuz
    mv /System.map /boot/System.map

    When I rebooted, there was no sound. I tried alsamixer, but it gave some "snd_ctl_open failed ..... no such device" error. What do I do?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    For the 30,000th time, there is no need to compile your own kernel

    use the packages from the second CD, then you won't break anything and your sound will work fine.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    2

    Try alsa drivers

    Sasho:

    You may need new alsa drivers. Or you may just need to reinstall them with your new kernel. Try alsaconf and see if that works. You shouldn't be running any alsa at the time, so boot to a command line and try alsaconf, follow the prompts and (assuming it reports successfully finding your card and all) reboot.

    If that doesn't work try installing the latest alsa drivers.

    This is just a guess on my part, because I don't know what exactly is going on. It has worked for me in the past, however.

    I guess kern might know better, but it looks like he just wants to look like he knows better. Personally, I always compile my own kernels, even if I don't have to. That's one of the cool things about Slackware. In fact, it would seem to me you're confused about the nature of Slackware and its users if you tell one to not compile his own kernel. But then, I don't come here much.

    Anyway, good luck.

    joe f.

  4. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Sorry

    its just the only thing I seem to post here anymore

    "why build your own kernel when the default binary package supports dual core / HT / SMP / HIGHMEM"

    think about it, you can upgrade the binary packages whenever they get updated in the slackware repository. why spend 30minutes to an hour compiling and breaking a kernel every time you upgrade? when it takes two package upgrades and a reboot? around 20 seconds.

    that is all, unless you have specific hardware that isnt compiled into the kernel by default, which is unlikely in my opinion, then I just don't see the point. I used to compile my kernels because Pat's config never had SMP included, now it does, and I never need to roll my own kernels any more.

    I'm just saving you time , frustration, and effort

  5. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    21
    I want a working 2.6.XX kernel, because some of the programs I tried to install required it. How can I install a binary kernel?

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    as root

    Code:
    init 1
    removepkg /var/log/packages/kernel-generic*
    removepkg /var/log/packages/kernel-modules*
    insert and mount the 2nd slackware cd, and in testing/linux-2.6.x/packages or similar, you'll find the appropriate 2.6 kernel and module packages. install them

    Code:
    installpkg kernel-blah*.tgz
    installpkg kernel-blah-modules*.tgz
    /sbin/lilo -v
    don't install the kernel-2.6 headers package, you're supposed to use 2.4, even on a 2.6 kernel.

    reboot, and you'll have 2.6 .. hopefully

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    21
    Had to use initrd cause my file system is ReiserFS but then the new kernel worked like a charm

  8. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    thanks kern

    no problem man

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •