Find the answer to your Linux question:
Results 1 to 4 of 4
Hi. I have recently installed Slackware 11.0 with the huge26.s kernel. Immediately after the successful installation I downloaded the NVIDIA IA32 driver for Geforce. But when I started the installation ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    13

    Problems installing NVIDIA driver with Slackware 11.0


    Hi.

    I have recently installed Slackware 11.0 with the huge26.s kernel. Immediately after the successful installation I downloaded the NVIDIA IA32 driver for Geforce. But when I started the installation I got the following message:

    Code:
    ERROR: Unable to load the kernel module 'nvidia.o'. 
    This happens most frequently when this kernel module was 
    built against the wrong or improperly configured kernel sources 
    with a version of gcc that differs from the one used to build the target kernel,
     or if a driver such as rivafb/nvidiafb is present and prevents the NVIDIA kernel 
    module from obtaining ownership of the NVIDIA graphics device(s).
    
    Please see the log entries 'kernel module load error' and 'kernel messages;
     at the end of the file '/var/log/nvidia-installer.log' for more information
    When I check the log files I get the following:

    Code:
    -> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.o':
       -1 Invalid module format
    -> Kernel messages:
       0000:05:08.0: 3Com PCI 3c905C Tornado at f8ccc000.
       shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
       i2c_adapter i2c-0: nForce2 SMBus adapter at 0x1c00
       i2c_adapter i2c-1: nForce2 SMBus adapter at 0x1c40
       ACPI: PCI Interrupt Link [LACI] enabled at IRQ 3
       PCI: setting IRQ 3 as level-triggered
       ACPI: PCI Interrupt 0000:00:04.0[A] -> Link [LACI] -> GSI 3 (level, low) ->
       IRQ 3
       PCI: Setting latency timer of device 0000:00:04.0 to 64
       intel8x0_measure_ac97_clock: measured 54716 usecs
       intel8x0: clocking to 46899
       input: PC Speaker as /class/input/input3
       parport0: PC-style at 0x378 [PCSPP,TRISTATE]
       lp0: using parport0 (polling).
       lp0: console ready
       Linux agpgart interface v0.101 (c) Dave Jones
       Capability LSM initialized
       Intel ISA PCIC probe: not found.
       Databook TCIC-2 PCMCIA probe: not found.
       firmware_class: exports duplicate symbol release_firmware (owned by kernel)
       NET: Registered protocol family 10
       lo: Disabled Privacy Extensions
       IPv6 over IPv4 tunneling driver
       eth0: no IPv6 routers present
       i2c_core: exports duplicate symbol i2c_register_driver (owned by kernel)
       No module found in object
    I am figuring that, since the NVIDIA-installation surely is supposed to work after a fresh stable Slackware install, I must have done something wrong during the Slackware installation. Therefore, I will explain some key choices that I did during the installation:

    1. After booting the cd, I typed: huge26.s
    2. I then ran 'fdisk' to setup the partitions, and then typed 'setup'
    3. The installation ran, and then I was prompted to choose the kernel. I chose huge26 from the cd, and then I was asked to pass any additional parameters to the kernel, which I didn't do.
    4. The installer finished, and I immediately started X to download the NVIDIA drivers.

    I'm figuring that I've done something wrong in one of these steps, and maybe I should have passed some parameters to the kernel?

    Any help would be appreciated.

  2. #2
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    When you installed your 2.6 kernel, did you also install its source and modules (2nd CD).
    I did have some problems with a previous nVidia installer (an easy kernel patch fixed that), the latest one seems to work fine though.

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    13
    Quote Originally Posted by jens
    When you installed your 2.6 kernel, did you also install its source and modules (2nd CD).
    I did have some problems with a previous nVidia installer (an easy kernel patch fixed that), the latest one seems to work fine though.
    Thanks for your reply.
    I have only installed the modules, not the source. I did not know that this was necessary, since I thought that source-installation was done automatically.

    I will try installing it and get back.

  4. #4
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Framebuffer

    Hi,

    I had this same problem. The issue (most likely) is with the stock Slackware kernel having been built with "framebuffer" support. The best way to alleviate this problem is to build your own kernel.

    1. Install the kernel source from CD #2 /extra/linux-2.6.17.13/
    #cd /mnt/cdrom/extra/linux-2.6.17.13/
    #installpkg kernel-source-2.6.17.13-noarch-1.tgz

    2. Now the kernel source should be in /usr/src//linux-2.6.17.13

    #cd /usr/src//linux-2.6.17.13
    #make menuconfig

    At this point you need to make sure that framebuffer support is turned off.

    In the menu go to:

    Device Drivers --->
    Graphics support --->
    < > Support for frame buffer devices
    ^Make sure this option is blank (not * or M)

    exit the menu and say yes when asked if you want to save the config.

    Now:

    #make bzImage
    #make modules
    #make modules_install

    #cp System.map /boot/System.map-2617
    #cp arch/i386/boot/bzImage /boot/vmlinuz2617
    #vi /etc/lilo.conf

    add the following lines to the bottom of lilo.conf
    ------
    image = /boot/vmlinuz2617
    root = [you need to put the same device here as in the root entry above eg /dev/hda1]
    label = linux2617
    read-only
    -----

    Now make sure that the "vga =" line in lilo.conf is set to "vga = normal"

    Save and exit editting lilo.conf.
    Now run lilo:

    #lilo

    You should see a line of output like:

    #Added linux2617

    Now you can reboot and you should have a new choice to load the new kernel in the lilo boot menu.

    Once you boot to the new kernel you should be able to compile the nvidia drivers.

    Lemme know if any probs.

    +charger-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •