Find the answer to your Linux question:
Results 1 to 6 of 6
I cannot see the Windows machines with samba, i think i miss something in my configuration file,i manage to let the windows machine to see mine. smb:/Home give me a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078

    Samba problem


    I cannot see the Windows machines with samba, i think i miss something in my configuration file,i manage to let the windows machine to see mine.

    smb:/Home give me a time out on server.

    my config file is:

    global]
    workgroup = Home
    server string = Ali-Liux
    security = user
    load printers = yes
    log file = /var/log/samba.%m
    max log size = 50
    socket options = TCP_NODELAY
    wins support = yes

    [home]
    comment = Home Directory
    path = /home/ali/
    valid users = nobody


    does anybody knows what is missing to see the Windows XP machines.

    Cheers.

  2. #2
    Just Joined!
    Join Date
    May 2007
    Location
    New Jersey
    Posts
    6
    Quote Originally Posted by aliov View Post
    I cannot see the Windows machines with samba, i think i miss something in my configuration file,i manage to let the windows machine to see mine.

    smb:/Home give me a time out on server.

    my config file is:

    global]
    workgroup = Home
    server string = Ali-Liux
    security = user
    load printers = yes
    log file = /var/log/samba.%m
    max log size = 50
    socket options = TCP_NODELAY
    wins support = yes

    [home]
    comment = Home Directory
    path = /home/ali/
    valid users = nobody


    does anybody knows what is missing to see the Windows XP machines.

    Cheers.
    Try adding these lines after the wins support line
    # the smb.conf man page
    ; hosts allow = x.x.x. x.x.x. 127.

    Where the x's are put the first three octets of your ip scheme. For example if your ip is 192.168.1.10 put in 192.168.1. 192.168.1. 127.

    That should allow your windows boxes to be seen by your server. If not then there is another line missing. Try posting your config here and I will sort through it to let you know what is missing. Also if you have an active firewall disable that and try it. I found that one time the firewall was retarded enough to restrict it so I added a line for samba.

  3. #3
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I was wrong it's working without the host allows, but my problem is the following, i'm using KDE so in my desktop there is a icon called system allow you too see some useful information but when i go to the Samba network there is the name of the workgroup (Home) but clicking on it gives me after 30 s timeout, if i ping in my konqueror (smb://192.168.1.2) directly to the ip of any other computer i can read the shared files ..... so how can i fix this ? imagine that i don't know wish ip correspond to wish PC,so it's a pain in a big Worgroup to start trying

    Thanks in advance for helping me.

    Cheers.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2007
    Location
    New Jersey
    Posts
    6
    Send me your smb.conf file copied into a txt file and I will look through it. I had the same problem as you months back and I found that there were 3 or 4 things I did wrong. I will look through yours and compare it to mine and see what I can find.

  6. #5
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    You can try webmin to configure samba.

  7. #6
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I'm just using know smb4k ,and everything is ok.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •