Find the answer to your Linux question:
Results 1 to 3 of 3
Hi! I am a complete newbie as far as Linux is concerned – been using Windows ever since my introduction to computers 10 years ago. Last week I was introduced ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    1

    Installation Problems


    Hi! I am a complete newbie as far as Linux is concerned – been using Windows ever since my introduction to computers 10 years ago. Last week I was introduced to Linux by one of my friends, read up a bit and downloaded three distributions that interested me, namely Fedora7, Debian 4 and Slackware 11 (DVD ISO’s). I bought a 160 GB SATA Hard Disk to facilitate these new operating systems on my computer. I started with the installation of Slackware and seem to have hit a brick-wall

    My Hardware:
    Processor: Intel Core2Duo 1.86
    Main-board: Intel DG965RY
    Memory: 2GB DDR2 RAM
    Hard Drive1: Seagate 160 GB SATA HDD ST3160211AS (Windows) Installed on SATA PORT 1
    Hard Drive2: Seagate 160 GB SATA HDD ST3160211AS (New) Installed on SATA PORT 3
    DVD: LG DVD-RW
    Floppy: No floppy drive present
    I first loaded in my Windows XP Disc and created four (RAW) partitions of approximately 40 GB each. I then booted up my computer using the Slackware DVD. My first problems were in loading the right kernel. The default kernel sata.i didn’t help me as ‘fdisk’ couldn’t open the drive. After a lot of trial and error which involved a lot of reboots I loaded the kernel test26.s through which fdisk could be used.

    Through the kernel test26.s , using fdisk I could partition the drive which is recognized as /dev/sdb1. I started by partitioning a 2GB space on this 40 GB allocation as a primary partition to be designated as root partition. I created an extended partition for the rest of the space (38 GB) and created logical partitions for them, which included /swap, /usr, /tmp and /home. All this goes fine, but when I write the data fdisk gives me a warning which says

    WARNING: Re-reading the partition table failed with error 22: Invalid argument (I don’t know if this is a problem)

    My partition details as displayed by fdisk
    Device Boot Id System
    /dev/sdb1p1 83 Linux
    /dev/sdb1p2 5 Extended
    /dev/sdb1p5 82 Linux swap
    /dev/sdb1p6 83 Linux
    /dev/sdb1p7 83 Linux
    /dev/sdb1p8 83 Linux

    Because of the warning displayed I rebooted my system and find that the partitions have been created, but when I run setup from the installation prompt I am unable to add swap partitions or setup target partitions, using the options available in the setup menu. Why isn’t my swap partition being recognized and moreover, why isn’t any other partition that I created using fdisk being recognized? The Add Swap option displays this

    NO SWAP SPACE DETECTED
    You have not created a swap partition with Linux fdisk.
    Do you want to continue installing without one?


    When I try to set up a target partition only the partition which I created from windows (/dev/sdb1) is being recognized. The other partitions (/dev/sdb1p1 … /dev/sdb1p8 ) which have been created with fdisk are not found in the menu list.

    The final problem which I face is the source drive is not recognized – meaning to say that my DVD-RW is not being read from. I thought this would be because maybe DVD-RW’s are not recognized (at least initially), so I bought a DVD Drive but even that doesn’t seem to solve the problem. Right now I have created a temporary FAT partition [NTFS partition doesn’t work – learnt it the hard way ]which holds the slackware source on the second hard-drive, which seems to have solved the problem temporarily, but I still wonder why is it that the source drive is not read from, when the initial booting is done from that.

    I think I am committing a mistake somewhere, but I am unable to figure out what it is. So if somebody who knows their way around Slackware can help me out I would really be very grateful indeed.

    P.S. I tried installing Slackware to my old laptop – Dell Inspiron 4000, everything worked right down to where it says, ‘Installation complete – reboot’ (or something to that effect). But when I reboot, I get the words GRUB on the screen and nothing else and nothing happens from thereon except the cursor blinking. Wonder why? Will try installing Slackware to my Lenovo Z60m IBM ThinkPad and my newer Dell Inspiron XPS M1210 late next week and see what happens.

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Welcome to the Linux community

    If you are completely new to Linux i suggest for you to use one of the following distributions: Ubuntu,Opensuse.

    Slackware is very powerful but the problem is this OS needs a lot of configuration, and from the first experience with Linux this will be Hard, it was my case since 4 years ago i had to use Opensuse because it's much more easier to configure,once you see that your comfortable with Linux you can start using Slackware wish till know it's very good for servers.

    And also after a success install you'll have some difficulties With the packages, since you can install/remove Slack package(tgz) without knowing the dependencies for the Suse package (rpm) you can see it very easy .

    But if you insist to use it know we can go ahead ,i'm responsible for some server machines running Slackware in my work so i can help you,my mail is always public also.

    Cheers.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  3. #3
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    @darthteran
    Welcome to Gnu/Linux!

    You may want to give aliov's advice some consideration, and switch to a more ready made system like Ubuntu. If you, like me, however want the more hands on approach to computing, then you may want to stick with Slack. It's a wonderful distro once you get it running. And I don't think the problems you're encountering are all that difficult to overcome.

    I've found that once you understand the logic of the system, that Slack is very versatile, fast and powerful, as well as transparent. Yet, distro's as Ubuntu need less initial learning and work more out of the box. It's a matter of taste really, so that is up to you to decide.

    But, if you'd like to give Slack a second chance, you might want to try the following.

    Boot up from the DVD, and repartition your drives using cfdisk. That may be moereto your liking. You want to give more room for the root directory, 5 GB is very nice. And try to stick with the default kernel. I don't believe your problem lies in there.

    Some random thoughts on the rest you said:
    If you can boot via the DVD, than the drive works. But if you're not able to access the drive once you've booted your complete system, then the problem lies elsewhere. I can't make out where it could lie, since you've been unable to boot all the way to a working system. Try that first, and we'll see.

    Swap. What you've said about your swap partition, I don't really understand. You're not supposed to access your swap partition. But the install program should allow you to designate a swap partition. Now with 2 GB RAM, you might want to consider 1 GB of swap. That should work.

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •