Find the answer to your Linux question:
Results 1 to 8 of 8
ANSWER IS: I was attempting to connect to the external IP from within my LAN to test. Hello, I have SSHD running on my slackware 11.0 system. I am able ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! MrSpandex's Avatar
    Join Date
    Aug 2005
    Location
    Detroit, MI
    Posts
    18

    Unhappy Remote SSH not working


    ANSWER IS: I was attempting to connect to the external IP from within my LAN to test.

    Hello,

    I have SSHD running on my slackware 11.0 system. I am able to connect via Putty from my Windows box with the local IP (192.168.0.111), and I can even connect from the slackware box to itself using this same IP (192.168.0.111). What I am having trouble with is connecting to it using my external IP (68.XX.XX.XX). I cannot connect from either box. Both simply time out.

    I have forwarded port 22 on my router, which I am confident should work (I forward lots of ports) to 192.168.0.111, the local LAN IP. DHCP is off.

    The slackware box connects to the net just fine through Firefox and links. Its ifconfig output:
    Code:
    eth0      Link encap:Ethernet  HWaddr 00:D0:B7:21:A9:73
              inet addr:192.168.0.111  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:16518 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4977 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:3566389 (3.4 MiB)  TX bytes:2062364 (1.9 MiB)
              Interrupt:10 Base address:0x1000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1432 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1432 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:112744 (110.1 KiB)  TX bytes:112744 (110.1 KiB)
    Thanks in advance for any help. I <3 Slackware

  2. #2
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    i not very sure that this would help but can u ping the ip 192.xxx from 68.xxx?

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    That won't work as 192.x.x.x is a LAN address whereas the other is a WAN address. Is the port definitely forwarded correctly? Are you running ssh on port 22? On my router it lets you create the rule for port forwarding but it has to be activated seperately. What router are you using?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    478
    Here's what you need to do, you need to get some dns service, for that you have to set a fixed LOCAL IP, in other words, if you have four computers connected to your router then your router is most likely 192.168.0.1 and the rest go 2,3,4 so on so forth. In the router setup there's an option to give your box a fixed IP, such as 192.168.0.3 and no matter which comp is on first your IP is always reserved. Then you can get a free *.dyndns.org subdomain from Dynamic Network Services, Inc. -- DynDNS -- Welcome and that will automatically forward to your IP even if it changes the whole time.

    Good luck

  6. #5
    Linux Newbie
    Join Date
    Jun 2005
    Posts
    123
    Quote Originally Posted by netstrider View Post
    Here's what you need to do, you need to get some dns service, for that you have to set a fixed LOCAL IP, in other words, if you have four computers connected to your router then your router is most likely 192.168.0.1 and the rest go 2,3,4 so on so forth. In the router setup there's an option to give your box a fixed IP, such as 192.168.0.3 and no matter which comp is on first your IP is always reserved. Then you can get a free *.dyndns.org subdomain from Dynamic Network Services, Inc. -- DynDNS -- Welcome and that will automatically forward to your IP even if it changes the whole time.

    Good luck
    I don't think this will solve the problem.

    Can you post your /etc/ssh/sshd_config?
    Also, can you post the output of 'netstat -tulpn'?

  7. #6
    Just Joined! MrSpandex's Avatar
    Join Date
    Aug 2005
    Location
    Detroit, MI
    Posts
    18
    -=See Below=-
    Last edited by MrSpandex; 06-28-2007 at 06:07 PM. Reason: Answer found

  8. #7
    Just Joined! MrSpandex's Avatar
    Join Date
    Aug 2005
    Location
    Detroit, MI
    Posts
    18
    Got my answer from another forum. It was because I was testing from within my LAN.

    Sorry for all the trouble, and thanks for the advice

    I am an idiot.

  9. #8
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    That old chestnut

    I should have guessed, I've made that mistake myself

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •