Find the answer to your Linux question:
Results 1 to 8 of 8
Whenever I try to mount a usb flash disk I get A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934

    usb flash disk mount problem


    Whenever I try to mount a usb flash disk I get
    A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume"
    member "Mount" error name "(unset)"
    destination "org.freedesktio.Hal")
    Using slackware 12.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Are you in the dbus messagebus (or haldaemon ) groups ? if you are able to mount it as root ,so this is you problem , to solve it add yourself in these two groups.

    usermod -G dbus,messagebus (your_user_name) .


    Hope this helps.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  3. #3
    Linux Engineer valemon's Avatar
    Join Date
    Oct 2006
    Location
    Volos
    Posts
    934
    I have not yet made a user until I configure slack. So i am running as root. Also I cannot access the linux partition.
    Linux is like a Teepee, No Windows, No Gates, Only Apache Inside!
    Arch Linux
    Linux user #442041

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Run groups as root and see also root in wish groups he is !

    About the Linux partitions, tell me the whole story please .

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  6. #5
    Just Joined!
    Join Date
    Jul 2007
    Posts
    3

  7. #6
    Just Joined!
    Join Date
    Jul 2007
    Posts
    3
    You must enable HAL and D-BUS before using script vsupdfstab:
    Code:
    chmod +x /etc/rc.d/rc.messagebus
    /etc/rc.d/rc.messagebus start
    chmod +x /etc/rc.d/rc.hald
    /etc/rc.d/rc.hald start

  8. #7
    Just Joined!
    Join Date
    Sep 2007
    Location
    Tuscaloosa, Alabama
    Posts
    2
    Quote Originally Posted by aliov View Post
    Are you in the dbus messagebus (or haldaemon ) groups ? if you are able to mount it as root ,so this is you problem , to solve it add yourself in these two groups.

    usermod -G dbus,messagebus (your_user_name) .
    There is absolutely NO REASON for a user to be in the messagebus or hald groups. Don't do that.

    In order for HAL/DBUS to allow a user (ANY user, including root) to mount a device, that user MUST be a member of the plugdev group. It's a good idea to go ahead and add the user to the cdrom group as well, but plugdev will do what most people want.

    This is not a complicated concept; it's already documented in several common places for Slackware help, and yet still there is incorrect advice given regularly and others suggesting the addition of unknown custom software that modifies /etc/fstab dynamically. Sheesh.

  9. #8
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Yes you right , i was wrong, it's enough to be in the plugdev group .

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •