Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
Distro Slackware 12 1. My motherboard is Mobile Intel(R) 945GM Express Chipset Family I want to install graphics card driver. Please help. I have windows driver. I would also like ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117

    Graphics Card & NIC Driver


    Distro Slackware 12

    1.

    My motherboard is
    Mobile Intel(R) 945GM Express Chipset Family


    I want to install graphics card driver. Please help.

    I have windows driver.


    I would also like to install chipset driver if possible.


    2.

    How to configure to load module on boot?
    I want to load intel pro ve 100 network card driver.

    I have to run modprobe e100 on login and its very irritating.
    I didn't found e100 in /etc/rc.d/modules.

    Please help.

  2. #2
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Quote Originally Posted by littledrop View Post
    Distro Slackware 12

    1.

    My motherboard is
    Mobile Intel(R) 945GM Express Chipset Family


    I want to install graphics card driver. Please help.

    I have windows driver.


    I would also like to install chipset driver if possible.


    2.

    How to configure to load module on boot?
    I want to load intel pro ve 100 network card driver.

    I have to run modprobe e100 on login and its very irritating.
    I didn't found e100 in /etc/rc.d/modules.

    Please help.
    For the Graphic Card, if you have a intel vga that's great, only use the i810 driver in the xorg.conf , edit the /etc/X11/xorg.conf and replace the vesa under the device section with i810 ,this drivers support for intel 915/915GM/935/945 , and many others.

    For the chipset driver , you don't have to play with it, usually the kernel load the correct setting for your chipset

    for the network , even if there is no entry in the rc.modules put it by hand, in fact not all the modules are listen.
    also if you have a wifi card, make the rc.wireless executable chmod +x rc.wireless.

    Hope this helps
    Linux is not only an operating system, it's a philosophy.
    Archost.

  3. #3
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117

    display brightness

    Thanks. It worked.

    I wanna reduce the brightness, so I wen to display properties and se the brighness. It works but when I exit that settings box , display is back to lot of brightness.

    Here is the settings in xorg.conf

    Gamma 0.40 0.40 0.40 # created by KGamma


    Any idea?


    DefaultDepth 32 doesn't work with my card.
    Why? Does it needs very high end graphics card?

  4. #4
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Please could you post the screen section ! in you xorg.conf file ,and also what you receive when changing to 32 depth the X doesn't start ?

    for the Gamma, please tell me what do you want to do exactly ?

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  5. #5
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    That problem is solved. I ahve 2 more problems.

    I will post new thread if I can get solution in thsi thread.

    1. I get this error when I run startx for non-root user.
    call to lnusertemp failed (temporary directoris fail?) , check your installation.


    2. when I set default depth =32 I get this on startx

    (EE) intel(0): Given depth (32) is not supported by I830 driver

    I am using i810 driver.


    Thanks.

  6. #6
    Just Joined! r0k3t's Avatar
    Join Date
    Apr 2007
    Location
    Cleveland
    Posts
    13
    that is because 32 is actually 24... Set
    DefaultDepth = 24 and you will be in good shape.

  7. #7
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Quote Originally Posted by littledrop View Post
    That problem is solved. I ahve 2 more problems.

    I will post new thread if I can get solution in thsi thread.

    1. I get this error when I run startx for non-root user.
    call to lnusertemp failed (temporary directoris fail?) , check your installation.


    2. when I set default depth =32 I get this on startx

    (EE) intel(0): Given depth (32) is not supported by I830 driver

    I am using i810 driver.


    Thanks.
    try to use use simply intel instead of i810

    For the non root users , how did you add those user , they have a login shell and home ?
    Linux is not only an operating system, it's a philosophy.
    Archost.

  8. #8
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    1. Defaut Depth=32 still not working. I am using 24

    2. home directories are there.


    I have one more problem.
    I was following this guide http://wiki.beryl-project.org/wiki/I...l_on_Slackware

    Now I can't start X.

    I ran the optional steps to remove Xorg6.9.

    What to do?

  9. #9
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I'm lost , because you said from the beginning it's Slackware 12.0 , wish comes by default with Xorg 7.3 and you don't have to change your X in order to use Beryl/compiz these tow require Modular Xorg (7.0 and later ) , this wiki it's for Slackware 11.0 and i never follow it because the driver build for i810 doesn't seems to be okay , because i have some trouble with it with my intel graphic card .

    For your problem don't try to remove the Xorg ! since it's a pain to reinstall it again simply use intel instaed of i810 .

    For your default depht i guess there is something wrong in your X configuration , i don't have any trouble related to this under Slackware 12.0 and i'm using beryl !

    If you are planning to use it the best way it's to compile it from Source code , because there is a lot of dependencies that you can't know them if you install them from the standard Slac packages .

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  10. #10
    Linux Newbie
    Join Date
    Aug 2006
    Posts
    117
    Default Depth=32 is not working so I have moved back to 24.

    Now My main problem is beryl.

    Today I did lot of things.
    I begin with this guide.

    http://wiki.beryl-project.org/wiki/I...l_on_Slackware

    Deleted X and can't start the X after I log off.
    After that I dont know what happened as I keep on trying so many things to get the X working, I can't start KDE as well.

    Then I fixed that don't know how it hapened but its working.

    Now I can't login with non-root user as I told earlier.

    Then I moved on to this guide.
    '+'

    I downloaded all the packages, and make entries in xorg.conf though I used kororaa xorg.conf file to make changes as per the article.

    Now I can't run compiz not even its settings manager.

    Can you give me steps to install beryl?

    ----------------------

    Do you know repository for slackpkg (slackware 12)?
    I will try beryl with it.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •