Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hey, I just switched over from gentoo to slackware. The installation was amazing, way less time, no problems. Everything is worked out except for the sound. I have compiled the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7

    No sound, gone through all options


    Hey, I just switched over from gentoo to slackware. The installation was amazing, way less time, no problems. Everything is worked out except for the sound. I have compiled the driver into the kernel, as a module, installed alsa again, added my name to audio group, tried to find all the mixers and unmute them, everything is showing that my computer sees the sound card, loaded the modules, but no sound. I'm not even getting any errors, i dont think.

    I'm pretty sure this is a slackware related problem, becuase this is very odd. I've gone through this before in gentoo, but the problem was usually obvious. Or at least it gave me some feedback.

    Can anyone help me??

    thank you in advance
    vfronda

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !!

    did you execute 'alsaconf' command?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Newbie rudie_rage's Avatar
    Join Date
    Jun 2007
    Location
    Canada
    Posts
    133
    Quote Originally Posted by vfronda View Post
    Hey, I just switched over from gentoo to slackware. The installation was amazing, way less time, no problems. Everything is worked out except for the sound. I have compiled the driver into the kernel, as a module, installed alsa again, added my name to audio group, tried to find all the mixers and unmute them, everything is showing that my computer sees the sound card, loaded the modules, but no sound. I'm not even getting any errors, i dont think.

    I'm pretty sure this is a slackware related problem, becuase this is very odd. I've gone through this before in gentoo, but the problem was usually obvious. Or at least it gave me some feedback.

    Can anyone help me??

    thank you in advance
    vfronda
    Dont know what to say other than make sure the speakers are on and plugged in :P
    Have you tried another program? sometimes its just that a program has so many sound settings that you cant find them all to turn them on.
    Living the digital dream....
    Disclaimer: I may be wrong since I was once before.
    Breathe out so I can breathe you in ~~Everlong

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    You will always need to run 'alsaconf' after any Slackware install
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  6. #5
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    In addition to what was said about alsaconf, you should

    (a) check the permissions on your kernel module to make sure it's executable.
    (b) Modprobe your kernel module to manually load it.
    (c) And for the future, you might have to edit /etc/modules.conf to get it to autoload. This file might not exist but trust me it will be read if you create it and add your kernel module in there to be read. See this code in /etc/rc.d/rc.alsa--

    Code:
     
    # If there are ALSA modules defined in /etc/modules.conf, but
    # ALSA is not yet loaded, then load the modules now:
      DRIVERS=`modprobe -c | grep -E "^[[:space:]]*alias[[:space:]]+snd-card-[[:digit:]]" | awk '{ print $3 }'`
      if [ ! "$DRIVERS" = "" ]; then
        echo "Loading ALSA kernel modules."
        for module in $DRIVERS; do
          modprobe $module
        done
      fi

  7. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    I did run alsaconf, many times.

    how exactly do i check the permissions on the module.

    I think all the modules for the sound card are loaded, there are like 20 of them. sorry i cant be more of a help.

    vfronda

  8. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Search for your card on the ALSA card matrix

    Advanced Linux Sound Architecture - ALSA Soundcard Matrix
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  9. #8
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    To check if your module is executable, in the directory where your module is go ls -l.

    Do you know that your new module in particular is loaded, or just the old modules? It sounded like you were unsure there.

  10. #9
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    what directory can I find the modules. I checked my rc.alsa file, I don't know what I'm looking for. Also in /etc/modprobe.d/sound file it reads

    alias snd-card-0 snd-intel8x0
    alias sound-slot-0 snd-intel8x0

    thank you
    vfronda

  11. #10
    Just Joined!
    Join Date
    Dec 2006
    Posts
    7
    I don't know if this helps, but my cpu beeps instead of the speaker making sounds, it's like my computer knows the sound is down and it beeps instead.

    thanks
    vfronda

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •