Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
I have 3 OSs installed on my computer, two of which boot. Slackware is not booting correctly for me at all. I must have something wrong with grub, but I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    27

    booting to slackware


    I have 3 OSs installed on my computer, two of which boot. Slackware is not booting correctly for me at all. I must have something wrong with grub, but I can't find out what it is, so here is the grub entry:

    title Slackware, kernel-generic-2.6.21.5
    root (hd0,3)
    kernel /boot/vmlinuz-generic-2.6.21.5 root=/dev/hda4 resume=/dev/hda3 ro
    initrd /boot/initrd.gz
    quiet
    savedefault

    [edit] when i try to boot, it gives me an error: 15, file not found. I checked but the files exist. I'm not so sure about the initrd line, which may be the problem, so I tried removing it, and it started to boot for like 5 seconds, but then gave me an error.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    In which partition did you install Slackware? Is it /dev/hda4? Does vmlinuz-generic-2.6.21.5 file exist in the /boot folder of hda4 partition?

    Boot up any other OS and Execute fdisk -l command. Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    I think the initrd it's the file how's not found .

    i guess it's Slackware 12 so you are using the generic kernel and there is a line indicate the initial ram device ,so have you done the initrd for your machine ?

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    27
    Quote Originally Posted by aliov View Post
    I think the initrd it's the file how's not found .

    i guess it's Slackware 12 so you are using the generic kernel and there is a line indicate the initial ram device ,so have you done the initrd for your machine ?

    Regards.
    I don't think I have done initrd, as I don't really know what it is. I was just trying to fill in the blanks from another entry that I copied.

  5. #5
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    This will not work , have a look in your /boot under slackware partition ,Slackware uses the huge kernel wish you can boot it without the initrd , so and correct the lines to pint to your Slackware kernel and remove the line concerning the initrd.

    Regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  6. #6
    Just Joined!
    Join Date
    Dec 2006
    Posts
    12
    In my grub menu list this is the entry for Slackware 12.
    Slackware on hdb6
    title Slackware
    kernel (hd1,5)/boot/vmlinuz-huge-smp-2.6.21.5-smp root=/dev/hdb6 ro vga=791

  7. #7
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    Quote Originally Posted by driton View Post
    In my grub menu list this is the entry for Slackware 12.
    Slackware on hdb6
    title Slackware
    kernel (hd1,5)/boot/vmlinuz-huge-smp-2.6.21.5-smp root=/dev/hdb6 ro vga=791
    post the output of fdisk -l , make sure that the name of the Slackware kernel is as you mentioned above . try to put like this

    root (hd1,5)
    kernel /boot/vmlinuz-huge-smp-2.6.21.5-smp root=/dev/hdb6 ro vga=791

    regards.
    Linux is not only an operating system, it's a philosophy.
    Archost.

  8. #8
    Just Joined!
    Join Date
    Feb 2007
    Posts
    27
    Quote Originally Posted by aliov View Post
    This will not work , have a look in your /boot under slackware partition ,Slackware uses the huge kernel wish you can boot it without the initrd , so and correct the lines to pint to your Slackware kernel and remove the line concerning the initrd.

    Regards.
    I did this, and got an error:
    VFS: cannot open root device hda4 or unknown-block (0,0)
    Please append a correct "root=" boot option
    kernel panic - not syncing: VFS: unable to mount root fs on unknown - block(0,0)

  9. #9
    Linux Engineer aliov's Avatar
    Join Date
    Dec 2006
    Location
    Geneva,Beirut
    Posts
    1,078
    So this is not your Slackware root partition so please post the output of fdisk -l .
    Linux is not only an operating system, it's a philosophy.
    Archost.

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Post the contents of /etc/fstab and /boot/grub/device.map files too.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •