Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy 2 Problems - SuSE 10.0 & KDE 3.5


    Hi, I am new to linux and am really enjoying SuSE 10.0 unfortunately I have a couple of.... things, that I can't get to work that are starting to bug me and any help with solving the problem would be appreciated.

    1) I am using a Compaq Evo N600c what has the usual 4+ internet keys and of course a Fn key for adjusting contrast etc,. In KDE I have the right keyboard set but couldn't find anywhere to adjust the settings (the Fn key works but not with all buttons, example I can turn Num lock on but can't adjust contrast both use Fn). I have also tried lineakd to setup multimedia keys but can't get that to work. Any suggestions ??

    2) KDE 3.5 has the cool feature of when inserting a media device (DVD /iPod) it asks what you want to do. I have tried adding my own option so that when I insert a DVD xine is an option and it will start and play DVD automaticly (xine -pd) setting up is fine (and the command works, might have it wrong here) but when I run the option I get the following error: "Error - KIOExec" '/media/dvd is a folder, but a file was expected'. Same thing happens when I try to auto launch Gtkpod.

    Sorry about the long post I have tried googling with no luck the problems are probably more KDE then SuSE so sorry if the post is in the wrong place Again, any help appreciated.

  2. #2
    I'm having the EXACT same problem with my ipod - why in the world doesn't KDE execute the bash script I wrote when run from the ipod as it does when I choose run in KDE? I think it's a bug, guess I should try to find it and file it... not signed up for the KDE bug filing system yet though...

  3. #3

    kde DVD autoplay problem - solved

    -->
    I had the same. I tried to configure different xine startup scripts:

    xine -p dvd:/
    xine --auto-play --auto-scan dvd
    xine %u

    but all failed. Then I found someone had the same problem in Ubuntu 5.10 and had posted the solution.

    He used

    xine --auto-play=fh dvd:/ #%u

    and I think the magic is the '# %u' at the end. My guess is that kde wants to send the url anyway and if the script does not have the %u, then kde does something like passing the url to kioexec or whatever.

    For those who does not understand the '# %u'; # is comment in shell scripts and everything after it on the same line will be discarded.

    So this little hack let's kde to put the url to %u and with # we can ignore it.

    --auto-play=fh means; f - fullscreen, h - hide controls


    ps. Somehow I got always some crash dialog after configuring the autoplay from Control Center -> Peripherals -> Storage media

    ps2. The Storage media configurator is a bit confusing. You must select 'DVD Video Disk' to the 'Media type:' if you want to configure the behaviour when a DVD is inserted. It took a while for me to figure this out, because the default selection is 'All media types' and whatever I inserted there didn't show up when I inserted a DVD.

$spacer_open
$spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •