Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Upgrading from 10.0 to 10.1 noob experience


    I've just performed the update from 10.0 to 10.1 and everything seemed to go very well at first, then I found a few showstoppers...

    The first hint of problems was during the initial update itself. I was given a huge list of apps that were installed already along with some details, sorry for the noob terminology here, but Yast2 couldn't resolve their status apparently, so I was given the choice of removing or leaving them as is. Interestingly, most of them were either games or updates I'd performed as per the JemReport for hacking Suse. I decided to remove everything in the list, just to be on the safe side. The update completed with no more errors.

    I was now confronted with a nice shiny new gui which is a big improvement on the already awesome KDE, if you believe that. Gnome is the one thing I've yet to play with at all, so can't comment. I tried opening several apps and couldn't find anything awry, until I tried Firefox. It just wouldn't open. No errors, nothing. So, I tried uninstalling it, rebooting and reinstalling. Same problem. I checked the system logs and couldn't find anything to indicate a problem relating to Firefox itself, but being a noob that doesn't mean there is nothing in there hehe!

    So, for the moment I'm using Opera. It's disappointing that Firefox has failed and unless I can work out how I'm supposed to diagnose and fix it, I'm stuck. A search online has so far proved fruitless.

    Another problem is that using my broadband connection through the network with Yast2 seems much slower on this version of Suse. Again, this is anecdotal and has not been timed, but I'm certain it wasn't this bad before the update. If I try to add a source for packages, Yast2 has frozen a few times for over 10 minutes. The addresses I've used (from the Suse website) open fine in Konqueror in a couple of seconds but just cause Yast2 to stop working, so I don't know what's wrong there. On one occasion, I couldn't quit Yast2, end current session, shutdown or anything else. I had to hard reset the laptop.

    All in all, I'm not happy with the update results. What's worrying me, apart from the issues above, is that there may be something more serious lurking in the background that I'm not aware of yet. I've tried once more with Firefox from one of the other package repositories. Same result. The only thing I can thnk of to do as a beginner is reinstall the whole lot on a clean drive and see what happens. To be fair, I was warned updates don't usually go to plan.

    There's also some very good info and caveats on this web page relating to upgrading from a previous beta version:

    Oh well, you live and learn! I'm off to install Suse again


  2. #2
    Weird. After being asked to swap the extras CD with disc 1 something like 5 times during the start of the fresh install, the installer just rebooted. Fair enough, I removed the CD expecting Yast to come back and carry on as it always does. Well, it did, but it's now displaying in what looks like a DOS window, complete with legacy graphics etc. It's like stepping back in time! What's that all about I wonder?

  3. #3
    Now I'm even more confused than I was, if that is humanly possible!

    I went through the install and picked out a number of packages I wanted in addition to the standard desktop install. KDE and Gnome featured prominently. The install completed and to my surprise I was dropped to a command prompt. I logged in and typed "startx". The response was that I have no X server installed! I must have really screwed up with the package selection! But I distinctly remember seeing just about everything KDE related ticked to install.

    This is turning into quite an experience. Install restart coming up

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts