Find the answer to your Linux question:
Results 1 to 10 of 10
I'm trying to install the latest nvidia driver, just released, with the GUI for dirver settings. YOU is no good cos Suse don't seem to support this new release yet, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6

    new nvidia driver


    I'm trying to install the latest nvidia driver, just released, with the GUI for dirver settings. YOU is no good cos Suse don't seem to support this new release yet, so I downloaded the nvidia installer.

    I can't run it because XWindows is still running with my older nvidia driver module loaded. CTRL+ALT+BACKSPACE restarts X but I can't find any way to exit X. I tried just going CTRL+ALT+F1 and logging in on the non-gui terminal but there's nothing I can do from there. Certain commands i tried like init, telinit and rmmod result in 'unknown command'.

    What's going on?

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    Okay, those commands are only recognised if you're root.

    But I still have trouble - the nvidia installer goes to compile a new kernel module and then can't find the kernel source files. I have the kernel source installed, but what I'm thinkling is that it's the wrong version of the source. My kernel according to uname -a is 2.6.5-7.65 but the kernel source according to yast (no matter how many times I update it in 'install and remove software' or 'you') is 2.6.4-52. Actually the last time I looked at the kernel source package in 'install and remove software' it had the correct version next to it (but the installer still wasn't working), but it let me update the kernel source anyway then said it was downloading the older version again.

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Code:
    ls -al /usr/src/
    Make sure the /usr/src/linux symlink is pointing to the correct kernel tree in /usr/src.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    Sorry, I have no idea what that means. The command you gave does seem to result in a discrepancy though, all but one line gives the newer version of the kernel:

    sean@linux:~> ls -al /usr/src/
    total 1
    drwxr-xr-x 6 root root 232 2004-07-01 22:33 .
    drwxr-xr-x 12 root root 344 2004-06-05 16:28 ..
    lrwxrwxrwx 1 root root 16 2004-07-01 22:33 linux -> linux-2.6.5-7.75
    drwxr-xr-x 3 root root 72 2004-07-01 22:33 linux-2.6.4-52
    drwxr-xr-x 21 root root 832 2004-07-01 22:33 linux-2.6.5-7.75
    drwxr-xr-x 3 root root 72 2004-07-01 22:32 linux-2.6.5-7.75-obj
    lrwxrwxrwx 1 root root 20 2004-07-01 22:33 linux-obj -> linux-2.6.5-7.75-obj
    drwxr-xr-x 7 root root 168 2004-06-05 17:33 packages

  5. #5
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552

    Re: new nvidia driver

    Quote Originally Posted by chombee
    I'm trying to install the latest nvidia driver, just released, with the GUI for dirver settings. YOU is no good cos Suse don't seem to support this new release yet, so I downloaded the nvidia installer.

    I can't run it because XWindows is still running with my older nvidia driver module loaded. CTRL+ALT+BACKSPACE restarts X but I can't find any way to exit X. I tried just going CTRL+ALT+F1 and logging in on the non-gui terminal but there's nothing I can do from there. Certain commands i tried like init, telinit and rmmod result in 'unknown command'.

    What's going on?
    Edit the file /etc/inittab as root and change the line as shown below.
    Code:
     
    # Default runlevel. (Do not set to 0 or 6)
    id:3:initdefault:
    Next time you bootup linux it will start in text mode instead of graphical mode.

    Login as root.
    run the nvidia installer to compile the new display drivers.
    Edit the /etc/inittab and change de line back to id:5:initdefault.

    Next time you boot it will be back in graphical mode and using the new display drivers.

    There is also another way, but since you're fresh in linux, this is the easiest way....

    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  6. #6
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    thanks for the help,

    I don't think booting into text mode will help. The nvidia driver actually doesn't seem to require X to be shutdown or the old driver module to be removed. As long as I do init 3 as root before running it (actually this takes you to text mode and does seem to shut down X) the nvidia installer says it detects an older nvidia driver and then I choose to overwrite the older one.

    The problem is after this when the nvidia installer tries to compile it's kernel module and can't find the kernel source, even though I have the kernel source installed, I think there may be a version discrepancy between my kernel and my kernel source

  7. #7
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Quote Originally Posted by chombee
    thanks for the help,

    I don't think booting into text mode will help. The nvidia driver actually doesn't seem to require X to be shutdown or the old driver module to be removed. As long as I do init 3 as root before running it (actually this takes you to text mode and does seem to shut down X) the nvidia installer says it detects an older nvidia driver and then I choose to overwrite the older one.

    The problem is after this when the nvidia installer tries to compile it's kernel module and can't find the kernel source, even though I have the kernel source installed, I think there may be a version discrepancy between my kernel and my kernel source
    Its beter to be safe.
    yep, running init 3 while logged in as root will do the job too, forgot to mention it...

    Run: rpm-qa | grep kernel
    and it will show what kernels and sources are installed.

    the source should look for the linux symbolic link in /usr/src
    does that point to the correct kernel sources ?
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  8. #8
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    No good!

    rpm -qa gives command not found,
    grep kernel causes the konsole to hang

  9. #9
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Quote Originally Posted by chombee
    No good!

    rpm -qa gives command not found,
    grep kernel causes the konsole to hang

    huh ? Weird.
    But it's a complete line rpm -qa|grep kernel
    Here is an output from my system:
    [martijnl@illith martijnl]$ rpm -qa | grep kernel
    kernel-2.4.22-1.2174.nptl
    kernel-module-nvidia-2.4.22-1.2188.nptlsmp-1.0.5336-0.lvn.3.1
    kernel-2.4.22-1.2188.nptl
    kernel-2.4.22-1.2115.nptl
    kernel-smp-2.4.22-1.2194.nptl
    kernel-smp-module-alsa-1.0.4-1_2.4.22_1.2188.nptl
    kernel-smp-2.6.7-1.459
    kernel-source-2.4.22-1.2194.nptl
    kernel-smp-module-alsa-1.0.4-1_2.4.22_1.2179.nptl
    kernel-smp-2.4.22-1.2179.nptl
    kernel-utils-2.4-9.1.101.fedora
    kernel-smp-2.4.22-1.2188.nptl
    kernel-ntfs-smp-2.4.22-1.2188.nptl
    aaahm, does suse use rpm ???????
    Just wondering.... Cuz i'm using fc1.

    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  10. #10
    Just Joined!
    Join Date
    Jul 2004
    Posts
    6
    okay, this has been due to my stupidity so i hope i haven't wasted anyones time. That grep kernel command still causes my terminals to hang, but the rpm command works now, as does the two commands combined (previously they hadn't worked combined which is why i was trying them seperately). I dunno why they weren't working before. Anyway I don't get nearly as much output as you do but it confirms that my kernel and kernel source are both 2.6.5-7.75.

    The problem was that the path to the kernel source that the nvidia installer was using was wrong, which is what the installers error message suggests. I got the installer command from the suse specific readme so i was saving this possibility up for later, assuming it was unlikely. But it turned out that I was using the installer command for the older kernel, with the newer kernel you have to specify the source path in the command. This is cos i wrote the commands down on paper so i could type them in from text mode and then neglected to look back at the instructions when i realised i had the newer kernel.

    Anyway it seems to work now, the installer complained that it couldn't properly remove the previous drivers because they had been installed via rpm (actually suse installed them during suse installation) and it failed to copy a couple of files. It also complained that I had a rivafb kernel module loaded and this would prevent the nvidia module from running properly. None the less, it all seems fine and now (for the first time in linux) i can activate anti-aliasing and anisoptric filtering thanks to the new nvidia-settings gui, this work just lovely and the driver seems to work fast and well.

    Thanks for the help, this has been a helpful forum, i will bookmark it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •