Hi there

I am using opensuse10.3 and for some reason I am having real problems with accessing mysql. I installed mysql through Yast, and from my understanding a default username 'root' is created and the password is blank. Therefore (logged in as root) I should be able to simply type 'mysql' and I get the mysql> prompt. However, on doing this I get the error

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)

I have tried changing my password using the command

mysqladmin -u root password mypassword

and i still receive the same error.

I am able to specify a password in /etc/my.conf, but that just changes the error message by saying 'using password: YES'.

From what I have read what I am doing should be very simple, but I just can't figure it out what's going wrong.
If anybody can shed some light on this problem for me I'd be very grateful

Cheers

p.s I have been using the following link to the mysql website to help me out, with no avail

MySQL AB :: MySQL 5.0 Reference Manual :: 5.7.8 Causes of Access denied Errors