Find the answer to your Linux question:
Results 1 to 4 of 4
I recently installed SuSE and wanted to install xchat. I downloaded the binary from the xcaht website, but when i tried to use the ./configure and the make/make install commands, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2

    SuSE 9.1 Personal GCC missing


    I recently installed SuSE and wanted to install xchat. I downloaded the binary from the xcaht website, but when i tried to use the ./configure and the make/make install commands, i got the typical "bash: make: command not found", so i check for gcc. entering gcc into the prompt yielded the "bash: gcc: command not found" gcc is also not in my /usr/bin directory. this seems very odd to me becuase shouldn't all linux distro's come with it? my SuSE version is 9.1 personal which i downloaded from the SuSE website.

    where is my gcc?

    any help will be appriciated,

    --tUse

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    when you install suse gcc (c compiler) is not installed by default.you have to check this package to be installed.if you don't have it use yast to add it and then make sure that when you type ./configure you are in the appropriate folder,i mean this one where you uncompressed the file you want to install..
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Posts
    2
    thanks, i got gcc and make installed but when i type ./configure in the xchat directory i got an error: compiler cannot create an executable, the config.log is as follows:

    $ ./configure

    ## --------- ##
    ## Platform. ##
    ## --------- ##

    hostname = linux
    uname -m = i686
    uname -r = 2.6.4-52-default
    uname -s = Linux
    uname -v = #1 Wed Apr 7 02:08:30 UTC 2004

    /usr/bin/uname -p = unknown
    /bin/uname -X = unknown

    /bin/arch = i686
    /usr/bin/arch -k = unknown
    /usr/convex/getsysinfo = unknown
    hostinfo = unknown
    /bin/machine = unknown
    /usr/bin/oslevel = unknown
    /bin/universe = unknown

    PATH: /home/tUse/bin
    PATH: /usr/local/bin
    PATH: /usr/bin
    PATH: /usr/X11R6/bin
    PATH: /bin
    PATH: /usr/games
    PATH: /opt/gnome/bin
    PATH: /opt/kde3/bin
    PATH: /usr/lib/java/jre/bin


    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##

    configure:1575: checking for a BSD-compatible install
    configure:1630: result: /usr/bin/install -c
    configure:1641: checking whether build environment is sane
    configure:1684: result: yes
    configure:1741: checking for gawk
    configure:1757: found /usr/bin/gawk
    configure:1767: result: gawk
    configure:1777: checking whether make sets $(MAKE)
    configure:1797: result: yes
    configure:1961: checking whether to enable maintainer-specific portions of Makef
    iles
    configure:1970: result: no
    configure:2031: checking for gcc
    configure:2047: found /usr/bin/gcc
    configure:2057: result: gcc
    configure:2301: checking for C compiler version
    configure:2304: gcc --version </dev/null >&5
    gcc (GCC) 3.3.3
    Copyright (C) 2003 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    configure:2307: $? = 0
    configure:2309: gcc -v </dev/null >&5
    Reading specs from /usr/lib/gcc-lib/i586-redhat-linux/3.3.3/specs
    Configured with: ../configure --prefix=/usr --with-slibdir=/lib --infodir=/usr/s
    hare/info --mandir=/usr/share/man --enable-shared --enable-threads=posix --enabl
    e-languages=c,c++,f77,java,objc --enable-__cxa_atexit --enable-c99 --enable-nls
    --enable-long-long --enable-multilib --with-gnu-as --with-gnu-ld --with-system-z
    lib --without-x i586-redhat-linux
    Thread model: posix
    gcc version 3.3.3
    configure:2312: $? = 0
    configure:2314: gcc -V </dev/null >&5
    gcc: `-V' option must have argument
    configure:2317: $? = 1
    configure:2340: checking for C compiler default output file name
    configure:2343: gcc conftest.c >&5
    /usr/bin/ld: crt1.o: No such file: No such file or directory
    collect2: ld returned 1 exit status
    configure:2346: $? = 1
    configure: failed program was:
    | /* confdefs.h. */
    |
    | #define PACKAGE_NAME ""
    | #define PACKAGE_TARNAME ""
    | #define PACKAGE_VERSION ""
    | #define PACKAGE_STRING ""
    | #define PACKAGE_BUGREPORT ""
    | #define PACKAGE "xchat"
    | #define VERSION "2.0.10"
    | /* end confdefs.h. */
    |
    | int
    | main ()
    | {
    |
    | ;
    | return 0;
    | }
    configure:2385: error: C compiler cannot create executables
    See `config.log' for more details.

    ## ---------------- ##
    ## Cache variables. ##
    ## ---------------- ##

    ac_cv_env_CCASFLAGS_set=
    ac_cv_env_CCASFLAGS_value=
    ac_cv_env_CCAS_set=
    ac_cv_env_CCAS_value=
    ac_cv_env_CC_set=
    ac_cv_env_CC_value=
    ac_cv_env_CFLAGS_set=
    ac_cv_env_CFLAGS_value=
    ac_cv_env_CPPFLAGS_set=
    ac_cv_env_CPPFLAGS_value=
    ac_cv_env_CPP_set=
    ac_cv_env_CPP_value=
    ac_cv_env_CXXCPP_set=
    ac_cv_env_CXXCPP_value=
    ac_cv_env_CXXFLAGS_set=
    ac_cv_env_CXXFLAGS_value=
    ac_cv_env_CXX_set=
    ac_cv_env_CXX_value=
    ac_cv_env_F77_set=
    ac_cv_env_F77_value=
    ac_cv_env_FFLAGS_set=
    ac_cv_env_FFLAGS_value=
    ac_cv_env_LDFLAGS_set=
    ac_cv_env_LDFLAGS_value=
    ac_cv_env_build_alias_set=
    ac_cv_env_build_alias_value=
    ac_cv_env_host_alias_set=
    ac_cv_env_host_alias_value=
    ac_cv_env_target_alias_set=
    ac_cv_env_target_alias_value=
    ac_cv_path_install='/usr/bin/install -c'
    ac_cv_prog_AWK=gawk
    ac_cv_prog_ac_ct_CC=gcc
    ac_cv_prog_make_make_set=yes

    ## ----------------- ##
    ## Output variables. ##
    ## ----------------- ##

    ACLOCAL='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run aclocal-1.8'
    ALLOCA=''
    AMDEPBACKSLASH=''
    AMDEP_FALSE=''
    AMDEP_TRUE=''
    AMTAR='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run tar'
    AR=''
    AUTOCONF='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run autoconf'
    AUTOHEADER='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run autoheader'
    AUTOMAKE='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run automake-1.8'
    AWK='gawk'
    BUILD_INCLUDED_LIBINTL=''
    CATOBJEXT=''
    CC='gcc'
    CCAS=''
    CCASFLAGS=''
    CCDEPMODE=''
    CFLAGS=''
    COMMON_CFLAGS=''
    COMMON_LIBS=''
    CPP=''
    CPPFLAGS=''
    CXX=''
    CXXCPP=''
    CXXDEPMODE=''
    CXXFLAGS=''
    CYGPATH_W='echo'
    DATADIRNAME=''
    DEFS=''
    DEPDIR=''
    DO_GTK_FALSE=''
    DO_GTK_TRUE=''
    DO_PERL_FALSE=''
    DO_PERL_TRUE=''
    DO_PLUGIN_FALSE=''
    DO_PLUGIN_TRUE=''
    DO_PYTHON_FALSE=''
    DO_PYTHON_TRUE=''
    DO_TCL_FALSE=''
    DO_TCL_TRUE=''
    DO_TEXT_FALSE=''
    DO_TEXT_TRUE=''
    ECHO='echo'
    ECHO_C=''
    ECHO_N='-n'
    ECHO_T=''
    EGREP=''
    EXEEXT=''
    F77=''
    FFLAGS=''
    GENCAT=''
    GLIBC21=''
    GLIB_CFLAGS=''
    GLIB_GENMARSHAL=''
    GLIB_LIBS=''
    GLIB_MKENUMS=''
    GMSGFMT=''
    GOBJECT_QUERY=''
    GTK_CFLAGS=''
    GTK_LIBS=''
    GUI_CFLAGS=''
    GUI_LIBS=''
    HAVE_ASPRINTF=''
    HAVE_POSIX_PRINTF=''
    HAVE_SNPRINTF=''
    HAVE_WPRINTF=''
    INSTALL_DATA='${INSTALL} -m 644'
    INSTALL_PROGRAM='${INSTALL}'
    INSTALL_SCRIPT='${INSTALL}'
    INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
    INSTOBJEXT=''
    INTLBISON=''
    INTLLIBS=''
    INTLOBJS=''
    INTL_LIBTOOL_SUFFIX_PREFIX=''
    LDFLAGS=''
    LIBICONV=''
    LIBINTL=''
    LIBOBJS=''
    LIBS=''
    LIBTOOL=''
    LN_S=''
    LTLIBICONV=''
    LTLIBINTL=''
    LTLIBOBJS=''
    MAINT='#'
    MAINTAINER_MODE_FALSE=''
    MAINTAINER_MODE_TRUE='#'
    MAKEINFO='${SHELL} /home/tUse/Desktop/xchat-2.0.10/missing --run makeinfo'
    MKINSTALLDIRS=''
    MSGFMT=''
    MSGMERGE=''
    OBJEXT=''
    PACKAGE='xchat'
    PACKAGE_BUGREPORT=''
    PACKAGE_NAME=''
    PACKAGE_STRING=''
    PACKAGE_TARNAME=''
    PACKAGE_VERSION=''
    PATH_SEPARATOR=':'
    PERL_CFLAGS=''
    PERL_LDFLAGS=''
    PKG_CONFIG=''
    PLUGIN_INCLUDES=''
    POSUB=''
    PY_CFLAGS=''
    PY_LIBS=''
    RANLIB=''
    SET_MAKE=''
    SHELL='/bin/sh'
    STRIP=''
    TCL_CFLAGS=''
    TCL_LIBS=''
    USE_INCLUDED_LIBINTL=''
    USE_MMX_FALSE=''
    USE_MMX_TRUE=''
    USE_NLS=''
    USE_OPENSSL_FALSE=''
    USE_OPENSSL_TRUE=''
    VERSION='2.0.10'
    XGETTEXT=''
    ac_ct_AR=''
    ac_ct_CC='gcc'
    ac_ct_CXX=''
    ac_ct_F77=''
    ac_ct_RANLIB=''
    ac_ct_STRIP=''
    am__fastdepCC_FALSE=''
    am__fastdepCC_TRUE=''
    am__fastdepCXX_FALSE=''
    am__fastdepCXX_TRUE=''
    am__include=''
    am__leading_dot='.'
    am__quote=''
    bindir='${exec_prefix}/bin'
    build=''
    build_alias=''
    build_cpu=''
    build_os=''
    build_vendor=''
    datadir='${prefix}/share'
    exec_prefix='NONE'
    gdkpixbufcsourcepath=''
    host=''
    host_alias=''
    host_cpu=''
    host_os=''
    host_vendor=''
    includedir='${prefix}/include'
    infodir='${prefix}/info'
    install_sh='/home/tUse/Desktop/xchat-2.0.10/install-sh'
    libdir='${exec_prefix}/lib'
    libexecdir='${exec_prefix}/libexec'
    localstatedir='${prefix}/var'
    mandir='${prefix}/man'
    mkdir_p='mkdir -p -- .'
    oldincludedir='/usr/include'
    perlpath=''
    pkgconfigpath=''
    prefix='NONE'
    program_transform_name='s,x,x,'
    pythonpath=''
    sbindir='${exec_prefix}/sbin'
    sedpath=''
    sharedstatedir='${prefix}/com'
    sysconfdir='${prefix}/etc'
    target_alias=''
    unamepath=''
    xchatlibdir=''
    xchatsharedir=''

    ## ----------- ##
    ## confdefs.h. ##
    ## ----------- ##

    #define PACKAGE "xchat"
    #define PACKAGE_BUGREPORT ""
    #define PACKAGE_NAME ""
    #define PACKAGE_STRING ""
    #define PACKAGE_TARNAME ""
    #define PACKAGE_VERSION ""
    #define VERSION "2.0.10"

    configure: exit 77



    WHAT SHOULD I DO, AGAIN, ANY HELP IS MUCH APPRICIATED

    --tUse

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    did you typed make install before ./configure?if so it won't work.if i didn't understood well make sure you are using the appropriate version of gcc to compile this program.i see that you're using gcc version 3.3.3..
    Linux For Ever!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •