Find the answer to your Linux question:
Results 1 to 4 of 4
HI.....I'm new to linux and I've recentley installed JAD 1.0 (with KDE) I'm trying to get VSTi to run in Rosegarden. I followed the instructions in the JAD wiki entry ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Location
    LOndon
    Posts
    3

    bash: syntax error near unexpected token `newline'


    HI.....I'm new to linux and I've recentley installed JAD 1.0 (with KDE)

    I'm trying to get VSTi to run in Rosegarden. I followed the instructions
    in the JAD wiki entry with dssi host. (With dssi-host - JackLab UserWiki)

    All good except last entry (in Konsole)
    jack@LAB:/usr/lib/dssi/dssi-vst>

    I get a syntax error as follows
    bash: syntax error near unexpected token `newline'

    I've tried copy/paste this entry and manually typed it in....same result

    Can anyone please help.

    I've searched this site looking for possible answers but no luck
    so please excuse me if this has been answered before

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by koni View Post
    All good except last entry (in Konsole)
    jack@LAB:/usr/lib/dssi/dssi-vst>
    It looks like this is the prompt you should get at the console rather than something you need to enter ... or you may have copied the wrong text into your message.

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    from the WIKI

    You should see a lot of text scrolling down the screen as it is building the VST cache. You know it has finished when it has returned to the standard prompt:

    jack@LAB:/usr/lib/dssi/dssi-vst>

    This is just the prompt but it will look different on your machine. It is not to be typed.


  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Location
    LOndon
    Posts
    3
    Thanks to Jonathan and Gogalthorp for replies.
    A simple error on my part I guess, however I still cant run VSTi.

    When I try to run a standalone VSTi , then the Konsole text says the Path is not set (although I've repeated the process several times) it even says the .dll is not in VST folder and I know it is.

    The script has run (seen loads of code etc)

    Any other possible solutions.

    I'm also dubious about the wine bit,

    Note: When you install wine, a .wine folder will be created in your home folder. A folder called 'drive_c' will be in there. This is your 'virtual C drive' for wine where you will find Program Files and windows folders. All your windows programs will be installed in the 'Program Files' folder.

    I've installed the VSTi into the VST folder (in home/username/vst)
    and ensured all the .dll files are in that folder

    Once again any help much appreciated

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •