Find the answer to your Linux question:
Results 1 to 7 of 7
i have opensuse 10.3 when i place a dvd movie into my dvd-rom, the movie doesnt automatically play. i have to manually go to file tab in vlc or movie ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    18

    my dvd movies dont start automatically


    i have opensuse 10.3
    when i place a dvd movie into my dvd-rom, the movie doesnt automatically play. i have to manually go to file tab in vlc or movie player and search for dvd or the first vob and open it.. why doesnt it start automatically when i put the dvd into the dvd-rom
    i dont know if my dvd-rom is mounted or unmounted and not sure if it matters
    how do i correct get DVD's to play when put in dvd-rom

    thanks

  2. #2
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191
    Having a DVD play when it enters the drive is something that I would not expect to happen. My guess is that you would have to have some sort of program looking to see if something has entered the drive, then if it is a DVD, will automatically open mplayer/vlc/etc.

    Not that it can't be done, or someone hasn't written a program to do so, but I don't think that is normally default behavior. Someone can correct me if I'm wrong.

    Also, to confirm your suspicions, you shouldn't have to mount the DVD in order to play it.
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    Quote Originally Posted by sdimhoff View Post
    Not that it can't be done, or someone hasn't written a program to do so, but I don't think that is normally default behavior. Someone can correct me if I'm wrong.
    Gnome desktop has this functionality built into it, though I'm not sure about KDE as I haven't used it in a long time. What desktop environment are you using?

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    I am not a SUSE user but in Ubuntu, whenever one insert DVD or VCD, default Media Player pops up and start playing it.

    Btw, which Desktop Environment are you using? Gnome or KDE? I have just tested it in Ubuntu Gnome and Totem Movie Player started playing DVD automatically.


    EDIT: I am bit late this time... beaten by BigTom.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Linux Newbie sdimhoff's Avatar
    Join Date
    Jan 2007
    Posts
    191
    Thanks for the correction.
    Linux since: 2001
    Gentoo since: 2004
    - - - - - - - -
    Translation:
    I fix things until they break.

  6. #6
    Just Joined!
    Join Date
    Apr 2008
    Posts
    18
    im using gnome. when i place an audio cd into the drive, mplayer automatically plays the audio cd because default player is set, but when i place a dvd in the dvd-rom it doesnt play it... i've tried to set a default player to the dvd but there isnt an option, only option in a volume tab is mount point, mount option, file system and same three setting on the drive.. i tried setting the default player to the video folder and/or vob files doesnt work?

    how do i autorun a dvd , is seems my cds autorun...

    thanks

  7. #7
    Just Joined!
    Join Date
    Apr 2008
    Posts
    18
    in opensuse 10.3 click on computer - control center- in the hardware section click removable drives and media- in multimedia tab put a check in play video DVD discs when inserted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •