Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    telnet not working on sles 10

    hi all,

    i'm new to linux, so please bear with me.

    I have just installed sles 10 on a dell poweredge 2900. i need to be able to telnet into this box.

    when trying to telnet, i get the following message:

    /usr/lib/mit/sbin/login.krb5 , no such file or directory.

    i have a specific need to use telnet, so if you can't provide a solution to this problem, please don't reply and tell me to use ssh or some other more secure program.

    i am aware of the inherent security issues with telnet.


  2. #2
    Just Joined! javilin93's Avatar
    Join Date
    Jun 2008
    check if the krb5-server package is installed

  3. #3
    thanks for your response.

    i'm not sure how to check to see if that package is installed and if it is not, i certainly don't know how to install it.

    i have checked the services under xinetd and there is no service named krb5-service shown.

    as i said i am very new to linux and do not understand a lot of the terminology yet.

  4. $spacer_open
  5. #4
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    West (by God) Virginia
    Go to Yast-Software-Software Management and do a search. If it is not installed select to install it.

    It really is pretty simple once you know where to go.

  6. #5

    telent not working on sles 10

    thanks. it was pretty easy once i realized that i needed to install it from the installation cd's.

    i found it on cd 3 and installed it and now i have the login.krb5 file.

    however, when i try telnet <ip address> i get a new message:

    "could not open connection to host, on port 23: connect failed".

    i think i am close.

  7. #6
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    West (by God) Virginia
    Did you open the port in the firewall??

  8. #7
    the firewall on the linux box is disabled. i tried to use telnet localhost and got the same message.

    i don't have a firewall on my pc.

    not being a network person, it does seem to me that some service may not be running. that is just a guess.

    again, thanks for your help. i really appreciate it.

  9. #8
    Do you have a telnet server installed? (The missing "i" to the left means it's not installed in the example below.)

    zypper se telnet
    Restoring system sources...
    Parsing metadata for SUSE Linux Enterprise Server 10 SP1...
    S | Catalog | Type | Name | Version | Arch
    | SUSE Linux Enterprise Server 10 SP1 | package | perl-Net-Telnet | 3.03-195.2 | x86_64
    i | SUSE Linux Enterprise Server 10 SP1 | package | telnet | 1.2-14.4 | x86_64
    | SUSE Linux Enterprise Server 10 SP1 | package | telnet-server | 1.2-14.4 | x86_64
    If installed, is xinetd listening for port 23 connections?

    chkconfig -l | grep telnet

  10. #9
    the chkconfig command shows 2 items
    ktelnet off
    telnet off

    in the network services screen under xinetd, i don't see ktelnet listed but i do have 2 listings for telnet,

    both of the telnet listings have a - (dash) in the status column. if i try to enable them, i get a popup message that says: Package telnet-server was successfully installed on one of them and the message: Package krb5-apps-server was successfully installed on the other one.

    thanks for you help!

  11. #10
    How are you trying to "enable" them?

    You need xinetd "on" and "telnet" on.

    chkconfig -s xinetd on
    chkconfig -s telnet on
    Then check them:

    chkconfig -l
    And see if port 23 is open:

    netstat -anp | grep 23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts