Find the answer to your Linux question:
Results 1 to 9 of 9
I found some information about installing mplayer to Suse and I have read all of them.I read refence pages on that pages.I don't know if I am missing something but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    Mplayer installation problems on SuSe 9.1?


    I found some information about installing mplayer to Suse and
    I have read all of them.I read refence pages on that pages.I don't know if I am missing something but I downloaded "MPlayer-1.Opre5.tar-bz2" when I say

    tar -xjvk MPlayer-1.Opre5.tar-bz2

    it returns me an error such =

    "tar:MPlayer-1.Opre5.tar-bz2 Cannot Open :No such file or directory"
    "tar:Error is not recovarable:existing now"
    "tar:Child return status 2"
    "tar:Errors exit delay from previous erros "(or somehthing like that)



    then I downloaded
    "MPlayer-1.Opre5-pm.1.i586.rpm"
    and tried

    rpm -ivh MPlayer-1.Opre5-pm.1.i586.rpm

    but I got nearly same thing
    could not open the file :MPlayer-1.Opre5-pm.1.i586.rpm

    Did I do something wrong?

    (Ps:These files in /home/MPlayer/.....)


    __________________
    Best Regards

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    Germany
    Posts
    49
    what version?

    check out http://packman.links2linux.de/?action=128

    read "man tar" and/or "man rpm"

  3. #3
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    are you sure that you are in the same directory that you downloaded the files?cause if you aren't you can't install it...(use cd command to go there and check with pwd command).
    Linux For Ever!

  4. #4
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Ok first I apolagize to everyone who reads this artcle because
    I made a huge mistake by seeing "0" like"O" in

    tar -xjvk MPlayer-1.-----O---pre5.tar-bz2 see.....

    But when i solve this and want to
    ./configure --enable-gui I got message

    The GUI requires GTK devel packages (which were not found)...
    and tells me to look at the configure.log file to see the error more detailed.I've looked at taht file but there is nothing.
    I installed every gtk packet I know but what am i doing wrong...
    I found some forum thread about this error but thre is no solution on them....



    Best Regards

  5. #5
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    Hi guys;


    I tried " ./configure " with no parameter it worked(OK i dont like menus either :P )

    But than when I wanna start mplayer ,I mean just for try it. It didn't worked.
    I wrote on the console

    mplayer filename.avi(or mpeg or mpg)

    a window opened but showed nothing execpt pinky slights or somethngs but not the video????Do you have any idea ...Thankss



    Best Regards

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2
    I had a similar problem with mplayer on Suse 9.1

    I bet that when you ran ./configure, there was an error in the middle of the output saying it couldn't find X11 development packages. To fix that, go into Yast2 and install the "XFree86-devel" and "XFree86-Mesa-devel" package. Then try to install mplayer again. If that doesn't work, there must be some other XFree86-* package needed. Suse has a habbit of not including all devel packages needed during the default install.

    Good luck.

  7. #7
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5
    At last I find what was the problem.....

    The problem is not the codec ; the problem is the output device that I selected.
    Ok ...When I said:

    mplayer -vo X11 filename.mpg

    it worked fine.But i could't figure out how can I make this change permanent.Do you know anything about that.Thanks

  8. #8
    Just Joined!
    Join Date
    Aug 2004
    Posts
    5

    OK---

    I found that i have to write something into a config file of mplayer in order to make permanent of x11...

    ~/.mplayer/config:

    vo=x11

  9. #9
    Just Joined!
    Join Date
    Aug 2004
    Location
    Columbus, Ohio
    Posts
    16
    If you want to install mplayer without a hassle, go to the packman site that was mentioned earlier.

    Packman has a Suse rpm for mplayer (make sure you download and install the listed dependicy rpms first).

    There is also a browser mplayer plugin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •