Find the answer to your Linux question:
Results 1 to 3 of 3
Help I am totally new SuSE but have a bit of experience to Mandrake 10.0. I have built my PC to 9.1 personal and everything is going OK except I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    Chester, United Kingdom
    Posts
    10

    SuSE 9.1 Personal - No Sound


    Help I am totally new SuSE but have a bit of experience to Mandrake 10.0.

    I have built my PC to 9.1 personal and everything is going OK except I can't get the sound card to work.

    It is just an Intel Sound Blaster compatible onboard sound card so nothing fancy how do I go about diagnosing what the problem is.

    I can't even find the sound card in the KDE control center. Any help would be much appreciated.

    David

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    did you searched in yast->hardware->sound if it is recognised?have you also checked lsmod command to see if the sound module is loaded?lspci command?
    if ur card is recognised check for sound levels in the mixers and turn them all up...
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Location
    Norway
    Posts
    9

    Muted sound, have you tried this solution from suse

    Have you tried this:

    Regards,
    Anders H.


    Muted sound after installation

    http://portal.suse.com/sdb/en/2004/0...ndsilence.html

    Muted Sound Card

    Applies to: SUSE LINUX 9.1
    Symptom
    Despite having been properly set up according to YaST, your sound card does not produce any sound. The problem can be temporarily solved by reconfiguring your sound card, but arises again as soon as the system is restarted.
    Cause
    ALSA volume settings are overwritten by the tools in the package kdemultimedia3-mixer when KDE starts.
    Solution
    Disable KDE's mixer support and use sound mixers for the ALSA sound system only (e.g., kamix). For this purpose, proceed as follows:

    1. Make sure all mixer applications have been unloaded. If not, you should see a speaker icon on the tray beside the clock in the lower right corner. In this case, right-click it and select Quit from the context menu.

    2.If the question [Should KAMix start automatically immediately after you log in?] pops up when closing the mixer, confirm with Yes and skip to steps 13 and 14 of these instructions.

    3. Start the YaST Control Center and select Software -> Install and Remove Software.

    4. Search for "kdemultimedia".

    5. Right-click the package kdemultimedia3-mixer then select Delete from menu that opens.

    6. Press Accept in the lower right corner.

    7. Finish the YaST Control Center.

    8. Open a console (e.g., press [Alt]+[F2] and run the command konsole.

    9. Enter the command su - in the console.

    10. Enter the administrator's (root) password when prompted to do so. No characters (asterisk or similar) are displayed when typing it.

    11.Execute the following commands in the given order:
    rcalsasound stop
    rm /etc/asound.state
    rcalsasound start
    alsactl store

    12. Log the root user out of the console by pressing [Ctrl]+[D].

    13. Enter the command kamix & .

    14. Confirm the pop-up message [KDEInit could not start "CheckHardware".].

    15. Close the console by pressing [Ctrl]+[D].

    Keywords: mute,sound,sound card,91,kde,kmix

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •