I tried rpm -U openldap2-client-2.2.6-34.i586.rpm and several other options.
this will install

liblber.so.199.3.4 and
libldap.so.199.3.4 etc...
but it tries to remove the
liblber.so.2 and
libldap.so.2
so rpm throws an error:

Failed dependencies:
liblber.so.2 is needed by (installed) shadow-4.0.3.-233
libldap.so.2 is needed by (installed) shadow-4.0.3-233

Thank you very mutch if you can help. If not, either.