Find the answer to your Linux question:
Results 1 to 9 of 9
I have read through many of the posts in the forum and found similar questions but I found the answers were not complete enough for me to understand...but keep the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18

    A similar Suse install Q.


    I have read through many of the posts in the forum and found similar questions but I found the answers were not complete enough for me to understand...but keep the answers coming, the posts are very helpful!

    I also just took the plunge into the penguin world. I installed SuSE 9.X and it went very smoothly. I was even able to negotiate myself a change in the root where it was installed But after I installed it and went to reboot, I could access Linux and 98 but XP would not boot. Before this, XP was my boot manager. I am guessing that Linux wrote over this part of the hard drive with its own bootmanager so that now XP will not boot. Can someone tell me how to fix this problem? I would like to be able to see all three OS. Actually, in a few days I am going to install a Chinese version of XP and another version of 98 to do specific graphics work with a multimedia device I have so it is important for me to learn how to resolve these conflicts.

    Thanks in advance for any help.

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    ok well unfortunely i cannot say whitch bootmanager Suse uses, anyone who knows, i can give a complete answer, but it is also likely that the YaST2 tool used by SuSE will encompass part of your needs.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    SUSE's default boot manager is GRUB. There is a common problem on systems using a combination of GRUB, parted and kernel 2.6.X. There's a fix on SUSE's web-site.
    OH NOOOOO!!!!!! You did it the way I said?

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Location
    Providence
    Posts
    1
    I'm having a similar problem and have looked around a bit for a solution I keep ending up here: http://portal.suse.com/sdb/en/2004/0...booting91.html

    I'm using SuSE Linux Personal 9.1 on a PentiumIII. My windows is XP.

    I've not had any success with the instructions provided at the above location, maybe someone can dumb down the directions for me, I’m totally new to Linux.

    This is the error message I get when I try to boot Windows:

    root (hd0,0)
    Filesystem tyoe is fat, partition type 0xc
    chainloader ,1

    NTLDR is missing
    Press any key to resart
    Solution
    One quick solution is to activate the LBA or large access mode under which the hard disk was previously addressed for the hard disks in the computer’s BIOS. It is important that the hard disk values are not set to "AUTO".
    I don’t understand what this means, what is it telling me to do? It looks like this is the preffered option, if someone can explain to me what it means and how to do it, I’d like to try it.

    I’ve already tried burning the “parted.iso” to disc, but I haven’t been able to get the point to try it.

    - Insert the installation CD or DVD (important: on AMD64 systems, insert the 32-bit side of the DVD). Boot the CD or DVD up to the point where you can choose one of the different installation types.
    - Press F6. A message will ask you to keep the driver update handy.
    I’ve inserted the disc and booted to the point where I can choose installation types and pressed F6 and nothing has happened. No message asks me about the driver update.

    - Use the arrow key to select the menu item “Installation”.
    - Enter the boot parameter “fixpart=1” and press ENTER.
    I’ve chosen installation and typed in “fixpart=1” but it just continues to try to install Linux.

    -When the message “Please choose the Driver Update” is displayed, remove the installation CD, insert the driver update CD you created, and press “OK”.
    This message never comes up, it just starts going through a new installation.


    I’ve been searching in various places to try to find a fix for this, and keep being lead to this one solution. Is there something else I can try if this doesn’t work?

    Is there something I can do from within Linux? Will trying to use “repair” on my XP disc just make my problems worse?

    Thanks for any help anyone can provide.

  5. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    Hi...thanks for the insight...I don't know if this makes any difference but I can boot to 98 and Linux but not to 98, Linux and XP, even though XP is already installed and (was) working on my computer.

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    Here is the message I am getting when I select the xp option from the boot manager:

    root (hd1,0)
    Filesystem type is fat, partition type 0xb
    Chainloader +1

    Invalid system disk
    Replace the disk and then press any key...

    disk boot failure, insert system disk and press enter.

    This does not seem to be the error that others are describing...or is it?

    T

  7. #7
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    Can I install a program like GAG, a freeware boot manager, in place of GRUB?

    http://www.softpedia.com/public/cat/13/4/13-4-14.shtm

  8. #8
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2

    to cotuit on lba

    One quick solution is to activate the LBA or large access mode under which the hard disk was previously addressed for the hard disks in the computer’s BIOS. It is important that the hard disk values are not set to "AUTO".
    I don’t understand what this means, what is it telling me to do? It looks like this is the preffered option, if someone can explain to me what it means and how to do it, I’d like to try it.
    It means that you need to go to your BIOS setup and change your hard drive's acces mode to LBA. You can probably do this if you press DEL during bootup. This will take you to your BIOS setup. Now it is usally the DEL key that takes you to BIOS, but it might be something different for your computer. So if it doesn't go to BIOS after you've pressed DEL you should check your motherboard manual. Actually it might be a good idea to find the manual anyway, because if you get to BIOS you have to find where you can change the settings for your hard drives. In my case it's in the menu Standard CMOS features. There your drives are all listed. Select the drive that isn't performing as it should and press ENTER. Now, where it says ACCESS MODE select LBA and you're done. Of course you also need to save changes.
    Ok. hope that helps

  9. #9
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    Hi...and thanks for the advice, but both of my hard drives are already set up as LBA drives. Anything else? Can I install another boot manager?

    T

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •