Find the answer to your Linux question:
Results 1 to 4 of 4
I have OpenSUSE 11 on a MSI Wind. The problem I'm having is with getting an AT&T USB Connect 881 modem working with it. When I go into YAST and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    93

    Problem getting AT&T USB Connect 881 working on OpenSUSE 11


    I have OpenSUSE 11 on a MSI Wind. The problem I'm having is with getting an AT&T USB Connect 881 modem working with it.
    When I go into YAST and select Hardware I look under USB and see AirCard (/dev/ttyUSB0) listed. When I expand that section it says:
    Bus: USB
    Class (spec): Serial Controller
    Class: Communication Controller
    Device identifier: 223318
    Device Name: /dev/ttyUSB0
    Device Names
    Device Numbers
    Device: AirCard
    Driver: sierra
    Drivers
    Under Drivers it has:
    Active: Yes
    modprobe: Yes
    modules (under modules it says modprobe sierra)
    Hwcfg Bus: usb
    Interface: 128
    Kernel Driver: sierra
    Model: Sierra Wireless AirCard
    Old Unique Key: AEDV.D(gvxkgM099
    Parent Unique ID: pBe4.gkSaZmjGyhD
    Resources
    Revision: 0.02
    Sysfs ID: /devices/pci0000:00/0000:00:1d.1/usb2/2-1/2-1:1:0
    Sysfs ID: 2-1:1.0
    UDI: /org/freedesktop/Hal/devices/usb_devices_1199_685_noserial_if0_serial_usb_0
    Unique Key: FKGF.zu_WTPzVMZ6
    Vendor Identifier: 201113
    Vendor: Sierra Wireless, Inc.
    hotplug: usb
    modalias: usb:v1199p6856d0002dc00dsc00dp00icFFiscFFipFF

    I apologize if I gave more information that necessary but I'm a newbie in general to Linux.
    I had the idea that a driver is not included for this AirCard with OpenSUSE but if I'm reading correct it appears there is a driver already in OpenSUSE. Is that correct?

    The question though is: How do I actually use this AirCard and connect? I have the KDE desktop and currently use KNetwork Manager to connect using the WiFi connection on this computer. Can i set up the AirCard with KNetworkManager and if so, how do I? Or is there another way I need to connect? Thank you for your help

  2. #2
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    This is not a wireless card in the traditional sense (802.11a/g), but it seems that it can be made to work. As you see, the kernel module (aka:driver) sierra is already set to load. I think that you just need to set it up

    I found some info that says to use the Kppd dialup application, Here are links to them:

    Sierra Aircard 881 USB & Linux
    Sierra Wireless Linux How-To

    You shouldn't need to install any driver, so skip that part of the How-To.

    If you would keep notes on what you do to get it to work, we would appreciate it if you would post back and give us the details. That way we have some info for others to use.
    Last edited by waterhead; 10-03-2008 at 01:32 PM.
    Please do not send Private Messages to me with requests for help. I will not reply.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    93
    I followed the below procedures:

    Open Kppp
    hit the configure button
    on accounts tab create new account
    connection name: "aircard" or whatever you desire
    phone number: *99***1#
    auth: pap/chap

    on the modems tab
    hit the "new" button
    name your modem
    *modem device: /dev/ttyUSB2
    now click on modem tab
    uncheck wait for dial tone
    hit the modem commands button
    init1 box enter: AT+CGDCONT=1"IP,"isp.cingular"
    hit the query modem button
    it should recognize and return info about the modem
    login ID: IFP@CINGULAR.GPRS.COM
    pwd: CINGULAR1
    will get you connected

    Here is the issue I'm having. KPPP wasn't on my distribution so I downloaded it from the repositories. After doing that I tried all the above but ran into some problems. The modem was on USB0 so I changed it to dev/tty/USB0.

    The problem is after I installed KPPP and opened it up it said that I don't have sufficient permissions to run:
    /usr/sbin/pppd
    Then below it says:
    Make sure that KPPP is owned by root and has the SUID bit set.

    What exactly does that mean? It seems I have to change permissions somewhere but since I'm a newbie I don't understand what I have to do.

    The next issue is I then follow all the procedures as I pasted above but then when I follow the procedure where it says to hit the query modem button it says: "Unable to create modem lock file."

    It appears I have everything set up but could this be because of the insufficient permissions or is this 2nd issue unrelated?
    Even though it gives the original permissions error message it seems to run the KPPP Program but I assume even though it's running it's not working correctly.

    Any idea how I can fix this or is there even another connect program that I should use instead of KPPP to use my USB 881 Connect Aircard for AT&T?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    There are some slight differences between the two How-To's that I linked to. Have you tried the Sierra Wireless one? It says to use the phone number *99#. Both How-To's are very clear that the device is located on ttyUSB2. Are you absolutely sure it is different on your system? Run this command and look for where it assigns the location to the device.
    Code:
    dmesg
    If you have everything correct, then it could just be a permissions problem. When I run KPPP on Fedora 8, it asks for the root password before it will start. If it isn't doing this for you, you need to run it as root. The Sierra Wireless How-To says to use "su", but I think you can use "sudo".
    Code:
    sudo kppp
    Enter your root password, and now try. You may want to configure the connection again, because you are now root, not the user, as before.
    Please do not send Private Messages to me with requests for help. I will not reply.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •