I have a problem here because I installed my SuSE10.3 in swedish, but will try and translate.

After 'bout a year with the system running smooth on a separate P-ata-disk I got an errormessage with the regular fsck that occurs every 20th boot:

fsck failed. Please repair manually and reboot. The root
file system is currently mounted read-only. To remount it
read-write do:
bash# mount -n -o remount,rw /
Attention: Only CONTROLL-D will reboot the system in this
maintance mode. Schutdown or reboot will not work.


I stopped there, tried to run fsck -n (without any changes) and got several error reports among them:
Superblock last mounted in the future. Fix? no
Superblock last written to in the future. Fix no

Pass1: Deleted inode nr........... has dtime 0. Fix? no
Pass 2-4, no errors
Pass 5: Checking group information consistency: Block bitmap differences; ---4 lines with block numbers. Fix? no

Number of free blocks counted is wrong (..... instead of ...... counted)
Inode bitmap differences -426626. Fix? no
Number of free inodes is wrong...... Fix? no

Warning Filesystem still has errors!

fsck.ext3 /dev/sdb6 failed (status (0x4) Run manually!


(Still I can boot the system to start in an ordinary way.)

I could not find any instruction how to run fsck on an unmounted /dev/sdb6 so I first tried to run it from a Debian installation I have got on another partition on the same disk. It made some corrections in the filesystem and it was finally error-free.... At least that what it looked like, and was reported.

When I returned to SuSE, and booted it failsafe I halted at login and ran a e2fsck -n and GOT NEARLY exactly the same errorreports as above!

Finally ran e2fsck "sharply" from the Rescue system on the installation DVD. Corrections were made to the filesystem. Finally it was error-free. -Returned to and booted SuSE failsafe, ran fsck -n and got exactly the same kind of error reports as I first got! Some block number were changed, but the same kind of errors. -And I was again asked to run fsck MANUALLY?

Other tests I've made indicates that there are no harddrive errors.

How do I run fsck manually?
And how do I do it on an unmounted filesystem?
And how do I do it in a way that SuSE accepts as "fixed?

Anyone (who doesn't recommend installing Ubuntu

Regards
Lars