Hi ..after struggling to configure my headset and succeeding I thought I should at post what I did to help Linux newbies like myself who like using the near idiot-proof newer versions!

I have a Lenovo T43 and am currently using Suse 10.2 (because Suse 11.0 just would not work properly!).

I bought a Logitech ClearChat Pro USB headset.

Eventually I configured it in YAST...like this (this involves quite a few instructions, but it IS EASY!)

1. <YAST / Hardware / Sound />
It showed only one sound card (the in- built one) configured as index 0 (in this case a AC'97 Audio controller

2. so I clicked on <Add> / then

3. Left column - <All>
Right drop down <USB Audio - Generic>

4. then <Next> ....

So now I had 2 configured sound configurations
0 AC'97 Audio controller
1 USB Audio

5. I selected the <USB Audio> then <Other> (drop-down on right) and selected <Volume>.

I increased sound volume and also mic volume (that was at 0)

Then <Finish> saving those settings ...


I then tested it on Personal Settings (Configure Desktop) / Desktop/ Sound/ and managed to get a sound in the headset, but couldn't test the mic... so I went into Skype and tested there (by calling echo 123). It didn't work....

6. I went back to YAST (to stage 5 above)...having selected the <1 USB Audio> and going back to <Other> (drop down on right) and selected <Set as primary card>

After selecting <Finish> and testing again on Skype, it worked fine...

I notice now that 2 configured YAST sound settings are
0 USB Audio
1 AC'97 Audio controller

I hope this doesn't mess sound up later, but imagine if I am not using the headset I might have to manually go back into YAST and change the "Set as primary card" to the in-built sound controller?

Anyway the headset works now, so I thought I should post this for others in a similar situation...

Hope this helps!