Find the answer to your Linux question:
Results 1 to 5 of 5
This isn't strictly a suse problem but I've failed to find a solution elsewhere and Suse is the os I'm running, so I'm hoping someone can help I've had to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    33

    Can't access router - no longer at the ip it was set to


    This isn't strictly a suse problem but I've failed to find a solution elsewhere and Suse is the os I'm running, so I'm hoping someone can help

    I've had to 'daisy-chain' two routers, the main router connected to the phone line I set to 192.168.0.1 and the second to 192.168.0.2, the second router is connected to the first via an rj45 cable to an ethernet port on each router

    All the computers are connected to the net just fine, samba, internal dns etc all working ok

    The problem I have is that the second router no longer appears to be at 192.168.0.2, nor have I been able to find what ip it is at ... and I've tried many!

    I could reset it to default and set everything back up again, but that would be pointless if the same thing just happened again, the ideal thing would be to find the ip it is at if it has in fact changed (or wy I can't access the router's config via that ip if it hasn't)

    The default ip for that router is 192.168.1.1 and I've tried every ip from 192.168.1.1 up to 192.168.1.10 as well as a load on the 192.168.0.0 range

    Does anyone know of any way I can determine what ip it's using, or even just list all the ip addresses on the lan soo I could narrow it down that way?

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    I'd log on to the first router and see where things are assigned. The last number in the IP can go to 255. If you are not using fixed IP addresses it is hard do tell exactly where a device gets assigned.

  3. #3
    Just Joined! JosipBroz's Avatar
    Join Date
    Dec 2008
    Location
    Ljubljana
    Posts
    17
    Hmmm... two things come to mind at first glance, none of which is correct, but anyway:
    1. Are you using DHCP on the main router? If that's the case, your secondary router may be given any address in the range, really. On the other hand, it should be possible to check the DHCP clients listed on the main router configuration pages.
    2. You probably disabled NAT routing, DHCP and all the unnecessary features on the secondary router: would it be possible that it's so stripped-down that now it's functioning as a simple bridge/switch, namely without actually having a proper IP?

    P.S. If it does have an IP, maybe you could hunt it down by appropriately connecting a computer to one of its ports and running
    netstat -nr
    or
    route.

    P.P.S. If the two routers are IDENTICAL models (I don't know that), how can you tell for sure WHOSE configuration pages you're actually accessing? What if it's the MAIN router you can't access?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    33
    I'm using fixed addresses all round, no dhcp, and the main router is only showing the computers connected, doesn't show the second router at all

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    link-local * 255.255.0.0 U 0 0 0 eth0
    loopback * 255.0.0.0 U 0 0 0 lo
    default www.routerlogin 0.0.0.0 UG 0 0 0 eth0

    Dns resolved NETGEAR Support Home Page to 192.168.0.1

    Here's the first two hops in a traceroute to linuxforums.org:

    traceroute to linuxforums.org (67.15.52.42), 30 hops max, 40 byte packets
    1 NETGEAR Support Home Page (192.168.0.1) 0.896 ms 0.749 ms 0.780 ms
    2 dr13.ennby.ov.easynet.net (89.200.128.19 77.019 ms 79.635 ms 99.429 ms

    As you can see everything above indicates there's no router at 192.168.0.2, it makes it look as if the machine I'm running those on is directly connected to 192.168.0.1, whereas it's not, it's cabled to the second one at 192.168.0.2

    What you said about it working like a simple hub is a thought I had myself, and in fact a friend was here earlier and said he's had the same in the past with daisy-chained netgear router 'hiding' themselves

    I wouldn't really be bothered about that except wireless is enabled on the router I can't access and I hadn't got round to securing it before the router 'hid' itself

    Router one at 192.168.0.1 is a netgear DG834G (802.11g)
    Router two at 192.168.0.2 is a negear rangemax WNR834B (802.11n)

    There's allsorts of reasons why I know I'm able to access the router at 192.168.0.1 and not the one at 192.168.0.2, like two routers not being able to both use the address 192.168.0.1, only the first router has the isp connection info, and so on

    I'm thinking it might be as well to just reset it to default, secure the wireless, and then 're-daisy chain' it, if it disappeared again at least I'd have the open wi-fi issue sorted out

  6. #5
    Just Joined! JosipBroz's Avatar
    Join Date
    Dec 2008
    Location
    Ljubljana
    Posts
    17
    What you're describing might be perfectly normal behaviour, although I can't really confirm that, having never daisy-chained any routers. Obviously the WAN port of the second router is not used, right? Consequently, there is no routing/NAT traversal going on, the signal never even gets further inside the second router, the only section of the second router actually being used and distributing packets is the "switch" with (4, probably?) ethernet ports. It is actually acting strictly as a switch and as such, it has no IP address in itself. That's my 2 € cents...
    Now, if this is correct, you should be able to connect to it if you can run a cable to its WAN port; that should allow you to detect its presence (and its IP address) but it will only allow you to access its configuration page if it's configured to "allow administration from any IP address" -- which sure as hell is not the default in any router I've seen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •