Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Originally Posted by gogalthorp ro shut down X That command doesn't work for me.. SuSE says that it can't find the command. When I edit xorg.conf I find that where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Nov 2008
    Location
    The Netherlands
    Posts
    20

    Quote Originally Posted by gogalthorp View Post

    ro shut down X
    That command doesn't work for me.. SuSE says that it can't find the command.

    When I edit xorg.conf I find that where "nvidia" should be at the driver line, there is "nv", I just changed anyway.. How can you save this? This has been my first time working with Vim..

    Thanks..

  2. #12
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    I have found that for some cards it is better to install the NVIDIA driver downloaded from the NVIDIA site using what is termed the hard way ( it is not all that hard) rather then using the Yast repository. It does require that you install (via yast) the kernel-source and the gcc compiler.

  3. #13
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Quote Originally Posted by plinders View Post
    That command doesn't work for me.. SuSE says that it can't find the command.

    When I edit xorg.conf I find that where "nvidia" should be at the driver line, there is "nv", I just changed anyway.. How can you save this? This has been my first time working with Vim..

    Thanks..
    Sorry I missed typed, that is not a command just an explanation. Should read

    to shut down X

    the command is
    init 3

    This will shut down all x related processes

    nv is the open source 2D NVIDIA driver. It should work. But your sax2 command should have repleced that with "nvidia"

    Note all sax2 does is to change the xorg.conf file.

    To edit and save xorg.conf you must be root.

    try using joe rather then vi/vim it is a much simpler editor. I like nano but I don't think it is installed by default anymore.

    joe /etc/X11/xorg.conf

  4. #14
    Just Joined!
    Join Date
    Nov 2008
    Location
    The Netherlands
    Posts
    20
    Ok, I did what you said, but now instead of a normal desktop, or the terminal, I get a konsole window in the top corner of my screen.

    What can I do now?

    Thanks.

  5. #15
    Linux User
    Join Date
    Sep 2008
    Location
    UK
    Posts
    358
    Are you manually installing nvidia drivers?
    If so, in the window you have, login as root and type:
    init 3.
    You will now get a full screen black console window. Login again as root.
    Install the drivers as per nvidia instructions.
    Once installed, run:
    sax2
    Configure your card and save/exit sax2.
    Now type:
    init 5
    If
    All went well, you should have a graphic login.

    Generally running as a normal user in a full screen terminal, to get a graphic display, try typing startx, gnomestart or kdestart.

    If you have a console window at the side of your graphical login, it means you have chosen a terminal login.
    At the bottom of your logon screen is an option 'Session Type'. Choose to login using whatever window managers you have installed.

  6. #16
    Just Joined!
    Join Date
    Nov 2008
    Location
    The Netherlands
    Posts
    20
    Yay, thanks! That worked for me
    Can you change the title of this thread to [SOLVED] ?
    Thanks

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •