Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
my windows is working fine. will it be affected by this change?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader problem


    my windows is working fine. will it be affected by this change?

  2. #12
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    correct entry should be
    Code:
    rootnoverify (hd0,0)
    chainloader +1
    If you already have Windows Grub entry working correctly they should not need to be modified.

    I thought your issue was Linux loading to recovery console rather than starting GUI. You didn't post /etc/fstab contents for comparison with partitions ... also for the root=.... part what is at the end of the numbers eg something like part-1 etc?
    You can also remove the splash=silent on the kernel line at boot time and check of you get any additional messages ... last couple of lines are likely to contain relevant information.

  3. #13
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Have you re-installed Opensuse or are you getting this information by using the Live CD? If you have three Opensuse entries when you boot to choose from, they should all appear in your menu.lst. Can you post that? It seems you are not copying these but re-writing them, right?

  4. #14
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader problem

    I had windows xp sp2. I installed suse 10.3 and it was working fine. the i installed a fresh copy of windows xp sp2. when i restarted it booted directly into windows. I inserted the suse 10.3 dvd and as said in one of the help manuals which came along with it i tried to use the new installation-> repair->yast... well something like that. but it didn't work.
    Then I just tried new installation-> update. After a while it restarted and the menu with options came:
    1.open suse 10.3
    2.windows
    3.suse failsafe
    4.suse xen(something like that and this came after I used the update option from the dvd).

    now when I get into any of the three it asks for root password and once i enter it it log in and something comes up as
    rescue~#


    i am able to see my files and all but how do i make the login proper as before?





    (repair filesystem) # fdisk -l

    when i used the command fidsk -l; something like this came up.

    Disk /dev/sda: 40 GB...
    ...
    ...


    Device Boot start end blocks id system

    dev/sda1 * 1 1275 7 HPFS/NTFS

    dev/sda2 f W95 Ext'd(LBA)

    dev/sda5 7 HPFS/NTFS

    dev/sda6 7 HPFS/NTFS

    dev/sda7 82 Linux swap/Solaris

    dev/sda8 83 Linux

    dev/sda9 83 Linux

    dev/sda10 7 HPFS/NTFS



    I didn't include all the details because I thought these shoud be sufficient.








    ### don't change this comment -YaST2(and something else)
    title open SUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-3 default root= /dev/dis/by-id/scsi-SATA(some long number) vga=0x314 splash= silent showopts
    initrd /boot/vmlinuz-2.6.22.5-3 default

    ###dont change this(...)
    title windows
    root noverify(hd0,7)
    chainloader(hd0,0)+1

    similar two more options for failsafe and xen

  5. #15
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I would suggest you post the actual entries for Opensuse from menu.lst file, including the "some long number" and also post the entries from your /etc/fstab file, particularly the root (/) , boot and any other opensuse partitions.

  6. #16
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader problem

    i think the long number is the sata disk no and will not be of much help.

  7. #17
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader problem

    contents of menu.lst





    ### don't change this comment -YaST2(and something else)
    title open SUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-3 default root= /dev/dis/by-id/scsi-SATA(some long number) vga=0x314 splash= silent showopts
    initrd /boot/vmlinuz-2.6.22.5-3 default

    ###dont change this(...)
    title windows
    root noverify(hd0,7)
    chainloader(hd0,0)+1

    similar two more options for failsafe and xen

  8. #18
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Back to the beginning. You had Opensuse and xp both working, problems with xp, re-installed xp. Whenever you re-install windows it overwrites the mbr, so now you can boot xp not Opensuse. To return to using Grub, you could have done the following:

    Log in to terminal/konsole as root and enter:
    grub (will get grub prompt: grub>)
    type: root (hd0,7)
    setup (hd0)
    quit (to exit Grub prompt)

    Can't really give you any advice on how to change the prompt as I don't really know what you did with the installation/update.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •