Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
I had windows xp sp2. I installed suse 10.3 and it was working fine. the i installed a fresh copy of windows xp sp2. when i restarted it booted directly ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader


    I had windows xp sp2. I installed suse 10.3 and it was working fine. the i installed a fresh copy of windows xp sp2. when i restarted it booted directly into windows. I inserted the suse 10.3 dvd and as said in one of the help manuals which came along with it i tried to use the new installation-> repair->yast... well something like that. but it didn't work.
    Then I just tried new installation-> update. After a while it restarted and the menu with options came:
    1.open suse 10.3
    2.windows
    3.suse failsafe
    4.suse xen(something like that and this came after I used the update option from the dvd).

    now when I get into any of the three it asks for root password and once i enter it it log in and something comes up as
    rescue~#


    i am able to see my files and all but how do i make the login proper as before?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Does rescue~# prompt appear on select Windows title too?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10
    no. it comes only when i select the suse option.

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    When you reinstall windows with another operating system on your computer, windows will overwrite the master boot record. That's why it re-booted after the xp re-install to windows. It eliminated your Grub bootloader, at least the portion which was in the mbr.

    If you log in to opensuse and as root user run command fdisk -l and post the output here, someone should be able to tell you the exact commands to re-install Grub bootloader.

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    It looks like GRUB has been re-installed but all options in menu.lst file are set for rescue mode only.
    Boot up from any LiveCD, mount / partition of SuSe and post the contents of menu.lst file here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10
    (repair filesystem) # fdisk -l

    when i used the command fidsk -l; something like this came up.

    Disk /dev/sda: 40 GB...
    ...
    ...


    Device Boot start end blocks id system

    dev/sda1 * 1 1275 7 HPFS/NTFS

    dev/sda2 f W95 Ext'd(LBA)

    dev/sda5 7 HPFS/NTFS

    dev/sda6 7 HPFS/NTFS

    dev/sda7 82 Linux swap/Solaris

    dev/sda8 83 Linux

    dev/sda9 83 Linux

    dev/sda10 7 HPFS/NTFS



    I didn't include all the details because I thought these shoud be sufficient.

  7. #7
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Quote Originally Posted by Sid_terminator View Post
    dev/sda8 83 Linux
    dev/sda9 83 Linux
    It looks as though you have Linux on either sda8 or sda9. You will need to mount the partitions and list contents ... try these ...
    Code:
    mkdir /sda8 /sda9
    mount /dev/sda8 /sda8
    mount /dev/sda9 /sda9
    cat /sda8/boot/grub/menu.lst
    cat /sda8/etc/fstab
    cat /sda9/boot/grub/menu.lst
    cat /sda9/etc/fstab

  8. #8
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    boot loader problem

    ### don't change this comment -YaST2(and something else)
    title open SUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-3 default root= /dev/dis/by-id/scsi-SATA(some long number) vga=0x314 splash= silent showopts
    initrd /boot/vmlinuz-2.6.22.5-3 default

    ###dont change this(...)
    title windows
    root noverify(hd0,7)
    chainloader(hd0,0)+1

    similar two more options for failsafe and xen


  9. #9
    Just Joined!
    Join Date
    Dec 2008
    Posts
    10

    contents of menu.lst

    seems like suse is present in sda8 and these wher the contents of menu.lst


    ### don't change this comment -YaST2(and something else)
    title open SUSE 10.3
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.22.5-3 default root= /dev/dis/by-id/scsi-SATA(some long number) vga=0x314 splash= silent showopts
    initrd /boot/vmlinuz-2.6.22.5-3 default

    ###dont change this(...)
    title windows
    root noverify(hd0,7)
    chainloader(hd0,0)+1

    similar two more options for failsafe and xen


    after i edit them is :wq the command to save and quit?

  10. #10
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your windows entry needs to be "rootnoverify", one word, no space and (hd0,0) not (hd0,7)

    title windows
    rootnoverify(hd0,0)
    chainloader +1

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •