Find the answer to your Linux question:
Results 1 to 6 of 6
Hi all, I m having the following problem. I need to upgrade php version from 4.3.4 to 5.2.8. As i noticed, during a search on the internet, i cant find ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3

    Suse Enterprise Server 9 with php version 5.2.8


    Hi all,

    I m having the following problem. I need to upgrade php version from 4.3.4 to 5.2.8.
    As i noticed, during a search on the internet, i cant find a rpm for this upgrade.
    Do i have to upgrade Suse version to the latest or i can avoid it?

    The reason i m asking is that the specific machine is "live" and i would like to avoid the upgrade of the operational system.

    I really need your advice and help!!

    Thanks in advanced!!

  2. #2
    Linux User
    Join Date
    Sep 2008
    Location
    UK
    Posts
    358
    Try getting the rpm for 10.3 from the opensuse repos. If this doesn't work, try the redhat fedora repos. If I remember suse9 was pretty campatible with redhat's rpms.
    If all else fails, you may need to install manually.

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    Thanks for the reply i ll try it.
    Hope it works!!

  4. #4
    Linux User
    Join Date
    Sep 2008
    Location
    UK
    Posts
    358
    I did a bit of digging yesterday. 5.2.8 must be the latest version - my opensuse gives 5.2.6 I think. You will probably have to look in the factory or development repos for 5.2.8.
    If all else fails, try asking on opensuse forums (forums.opensuse.org)
    Good luck.

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    Thanks,

    I dont really mind to have 5.2.8. I just need php more than 4.3.10.
    So 5.2.6 is just fine.
    Is it possible to send me the link to download the rpm?
    I cannot find it!!!!

  6. #6
    Linux User
    Join Date
    Sep 2008
    Location
    UK
    Posts
    358
    Search for perl in the 10.2 repo:
    Index of /distribution/10.2/repo/oss/suse/i586.
    If you have dependency problems, go to the perl homepage:
    Get Perl - perl.org
    Download from: ActivePerl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •