Find the answer to your Linux question:
Results 1 to 4 of 4
i have insatalled suse 10.1 on my pc last 2008 until next year something happen to to it,, the gui of the said suse10.1 dosent appear any more.. when i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2

    Red face [SOLVED] GUI dosent appear..


    i have insatalled suse 10.1 on my pc last 2008
    until next year something happen to to it,, the gui of the said suse10.1 dosent appear any more..

    when i see the screen failsafe.

    it direct to terminal just like pressing alt2

    but when i tried pressing alt1 alt2 alt3 etc.... gui dosent appear anymore

    can you please help me with this one......

    it is easier for me to use GUI than terminal because i dont know all the commands in linux..

    thank you.....

  2. #2
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    Location
    3rd rock from sun - Often seen near moon
    Posts
    1,758

    Smile

    After logged into terminal as root via failstate
    TRy
    startx
    to start you gui interface. Though i never tried startx with suse . This solution works well for other distros.

    In case If your /etc/inittab has an entry like this
    id:3:initdefault
    then change it to
    id:5:initdefault
    Ps:Make a backup of /etc/inittab file before editing.
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    -----
    FOSS India Award winning ext3fs Undelete tool www.giis.co.in. Online Linux Terminal http://www.webminal.org

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    It ma be that you did a kernel update and you are using a 3rd party 3D acceleration driver like NVIDIA if so you need to reinstall the driver so it hooks into the new Kernel.

    You can use a generic 2D driver to temporarily get a desk top until you can reinstall by logging on as root. Then

    init 3
    to be sure you shutdown all X related process
    edit the /etc/X11/xorg.conf file (to use joe editor joe /etc/X11/xorg.conf)
    change the line
    driver "somedriver" where somedriver is the name of the 3D driver
    to
    driver "vesa"

    save
    then
    init 5
    to start the GUI

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2

    Thumbs up Thank s guys>..

    THANK S GUYS>..

    for your help i just change init3 form init 5 and already work

    thanks so much.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •