Find the answer to your Linux question:
Results 1 to 3 of 3
I've just installed OpenSuSE 11.1 today, and I'm trying to get Opera working. I've downloaded the rpm from their site, but it comes up with the error: Failed dependencies: libqt-mt.so.3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! TTIO's Avatar
    Join Date
    Nov 2008
    Location
    UK
    Posts
    80

    Opera not installing


    I've just installed OpenSuSE 11.1 today, and I'm trying to get Opera working. I've downloaded the rpm from their site, but it comes up with the error:

    Failed dependencies:
    libqt-mt.so.3 is needed by opera-9.63-2474.gcc4.shared.qt3.i386
    I've had a look around with Google, and so I installed the qt libraries, but it still doesn't work.
    Any ideas (I really don't like FF...)?

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    It is best to install things from the repositories via Yast-Software-Software Management. You should not try to install from source unless you really know what you are doing. Yast will resolve all dependencies.

  3. #3
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    OTOH, if you know beyond a shadow of a doubt that you have resolved the missing dependency (which if done manually, YaST will not know about and therefore not acknowledge), you can select "ignore unresolved dependency - just here" in your resolution options.

    This is not typically the best way of doing things, and may or may not work for you, and could possibly cause problems in the future (esp. during upgrades). Ignore dependencies at your own risk.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •