Find the answer to your Linux question:
Results 1 to 4 of 4
hello all. thought i saw this in a thread yesterday but wasnt able to find it today so i am going to post it. I would really appreciate any help ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3

    bootloader suse 11.1


    hello all. thought i saw this in a thread yesterday but wasnt able to find it today so i am going to post it. I would really appreciate any help or insight into this boot problem i am having with opensuse 11.1. I have my system dual booting with windows xp. when i turn on my computer i have the asus express gate boot up then it takes me to the boot loader for suse where i was able to choose 11.1, 11.1 failsafe, and then windows. well at the bottom when choosing to boot into suse it says vga mode = 34a. well when i choose to go into suse it probes the video card and tells me that the selected video mode (34a) is not available and then list abailable modes (all lower resolution than what my screen is capable of displaying). well i then update my nvidia diplay driver once in yast and was able to get the full resolution once inside the gui. but everytime i reset it comes up as that mode and it WOULD let me boot into normal resolution if i erase that mode at the boot loader then it boots fine to the right resolution. so i decied to change the boot loader settings and i erased that code (vga mode = 34a) in YaST. then i reset to check the settings and now i am unable to even see the boot loader. all i get is a flashing bar in the upper left corner of the screen and it never goes to boot loader just stays there. so i am not able to get windows or suse to load. sorry for the long post, please help me!!!

  2. #2
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Two things.

    1) The kernel expects to recieve the vga= parameter in decimal, not hex. Some kernels can take the hex IF you add a "0x" in front of it.

    2) You have to add 400 to the decimal VESA mode (I don't understand why, it was just written that way).

    You can try:
    vga=0x34A or vga=842

    Finally, if you're running a server kernel, it may not respond to the vga= option at all (VESA modes not compiled). In this case, install and configure a program call SVGATextMode (yes, that's the proper case).

  3. #3
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    It's also possible that your kernel simply doesn't support a mode so high. the vga= parameter is only used in console mode, so if you typically use the X interface and only view the console for messages on boot and shutdown, choosing the highest mode available in your menu of options will probably be plenty sufficient. (I'm happy with 773 (1024x768@8bit))

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    3
    D-cat, thanks for your input. i was not aware that ther kernel needed those defaullt settings for the boot loader. It was originaly set to vga=0x34a and was never able to find that setting so thats when it would probe. well i was able to try and re-install the boot loader with the correct settings from the install-dvd. however everytime i went to finalize the install it would give me an error. so after many unsuccessful attempts i decieded to completly erase the exsisting partions and start from scratch install. so i did that it probed my card and of course came with the limited resolution. i installed the nvidia driver from source again. rebooted and then at the boot loader i was given a new video mode and it is: vga=0x31a. with the new mode it shows the limited resolution on boot loader then when the splash screen comes for kde it automaticly goes to the right resolution (1920x1080 24 bit). So I believe that the kernel doesnt support that video mode for the boot up but does recognize it once it gets to the desktop enviroment. the problem has seemed to work its self out. it just took some encouragment. thanks for the your help again d-cat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •