Find the answer to your Linux question:
Results 1 to 7 of 7
OK. I have tried everything I know to get ANY of my Suse versions to work on my hard drive. Are the Western Digital SATA drives supported by suse?? I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    20

    suse can't see my SATA hard drive


    OK. I have tried everything I know to get ANY of my Suse versions to work on my hard drive. Are the Western Digital SATA drives supported by suse?? I have tried to run suse 11.1 64bit dvd that I downloaded from site (my pc can support 64bit, details below). I have tried moving my SATA connection to various location on motherboard (SATA1, SATA2, SATA6, etc). I have tried to format my hard drive in many different formats (NTFS, VFAT, no format). I tried Installing from live cd version (at the moment that's how I am able to type this since my hard drive has no os on it). I even tried loading suse 9.1 which I have running just fine on my laptop (It asked if I wanted to load a 32bit os on a 64bit pc, still didn't see hard drive). I even tried to load a solo boot of suse (NO WINDOWS!) and got nothing. The best I can get is with the live cd which loads a lite version into the ram and runs a lot like DOS only with a GUI background (again this is how I am able to type this with no os installed on hard drive). PLEASE HELP. My hardware is listed down below:

    ASUS fx AM2+ motherboard
    AMD Phenom tri-core 2.1ghz
    4gb ram
    320gb Weatern Digital SATA hard drive
    1Gb ATI video card
    dvd burner (IDE)
    cd burner (IDE)
    memory card reader
    usb pci card

    Motherboard came with built-in video (I don't use since it's 256mb), ethernet, and sound. I design this pc to run any current (and future with minor upgrades) windows os. I was going to build a linux pc, but then decided that I don't need it, plus money supplies isn't available to build it at the moment. That's why I'm trying to setup a dual-boot system using suse 11.1 and windows xp. I really need help figuring out why suse doesn't want to play with my system. Again, PLEASE HELP.

    dlmo

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Try this

    go to bios and disable all special features for your HDD (like Advanced Host Controller Interface (AHCI) if there is one).

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    20
    OK, under advance options, I found an item called: SATA mode selection. the options for this are SATA mode, RAID mode, and AHCI mode. It was on SATA mode to start with. Still no hard drive. Thanks for having me to check that even though it didn't fix my problem.

    dlmo

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2008
    Posts
    20
    UPDATE: This morning I went into my BIOS and set them to default failsafe mode to erase any possible problems in the BIOS. Suse still can't see my hard drive. Suggestions?

    dlmo

  6. #5
    Just Joined!
    Join Date
    Jul 2008
    Posts
    20

    Question

    NEW UPDATE:
    I tried to set a FAT partition using my old win98se disk. Suse still can't see my SATA hard drive. Should I try a different Distro? Or will I have this problem with them as well?

  7. #6
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Setting a partition will not help. The installer makes its own partitions.

    This might help

    HD sata - openSUSE Forums

  8. #7
    Just Joined!
    Join Date
    Jul 2008
    Posts
    20
    Thanks for the link. Sorry for the delay in response. I used the benchtest utility in the link to find the exact model of my motherboard. Its a xfx nvidia 8200 series (which I knew) model # mi-a78s-8209 (which I didn't Know). I started some research on this board and found out I'm not the only one with this problem. There is a fix that I found (donno if it works yet) where I need to flash my bios, change my sata mode to ahci and then add pci=nomsi. My only question at the moment is for the last step in the fix I'm trying. Do I need to be in a command line enviorment and if so how to get there? Also if anyone has this board, please let me know if this works or if I'm missing something. Thanks.

    dlmo

    ps. I forgot that the asus board talked about in the specs part of the first posting was a board I bought in Sept 08 that was dead on arrival. Within 2 weeks I had this xfx so I sometimes get confused about the name of the board.
    Last edited by dlmo78; 03-02-2009 at 11:08 AM. Reason: Charify motherboard names

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •