Find the answer to your Linux question:
Results 1 to 2 of 2
I have managed to get my USB key to boot the mini-ISO (i586-NET). I can get as far as the initialise set up. It accepts when I point to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    61

    HDD Install 11.1


    I have managed to get my USB key to boot the mini-ISO (i586-NET).
    I can get as far as the initialise set up. It accepts when I point to the ISO on the hard drive, and proceeds boot to its beautiful green install page and to ask my language and keyboard, and continues with "system analysis". It gets to the last stage "Initialise Package Manager", and then YAST reports:

    Unable to create repository
    From: xxxxx (path)

    details: failed to mount xxxxxxxxx (path)

    History:
    can't find valid meta-data at xxxxx (path)

    It knows it is on my hard drive sdb1, it can read NTFS.

    I have tried telling it where to find the ISO (even though it accepted it at the very start) in various ways, but no good. How do I get over this last hurdle in to Linuxland....?
    Do I have to strip/expand the ISO?
    If so where do I point YAST to when I have done it?
    Surely I can use the packed ISO as a repository?

    This is really, truly driving me mental now.
    I have got to the failure page and tried pointing to
    /SU1110.001.ISO
    /SU110.001
    As: Auto, NTFS, NTFS-3g, ISO-9660 filesystems
    All these with various attempts in "name of repo" (what should this be? does it matter, or is this just a label for the repo later on?)
    I have tried Upper case and lower case
    I have tried with trailing slashes and without
    I have extracted the ISO and tried all of the above pointing to
    /SU/suse/i586 (I extracted to a directory C:\SU)
    and any and all combo's, all four filesystems with and without "plain RPM" checked
    Probably about 200 or more combinations.

    All I get is "no valid metadata", "repo type cannot be determined"
    I have tried editing in CONFIG before set up starts..

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    61
    After many more wasted hours I am still at the same point >>>>

    At the end of the system analysis/package manager YAST2 reports:

    Code:
    Unable to create Repository from URL 'hd:///name.iso?device=dev/disk/mydisk&filesystem=auto
    
    Details:
    [|] Valid metadata not found at specified URL(s)
    
    History:
    -[name.iso] hd:///name.iso?device=dev/disk/mydisk&filesysystem=auto Repository type cannot be determined.
    
    Try again?
    If I answer yes it goes to a form to put in details of where it should look for the repos, with the following boxes:

    Code:
    Repository name?
    I guess this is just a handle for later when I wish to set the priorities, but I have tried to enter as many different names for my iso as I can imagine might be relevant
    Then a box with disk type, a drop down menu with my disk already filled in.
    Then a drop down with filetype, default auto.
    I have tried all possibilities, auto, ntfs, ntfs-3g, iso-9660.
    Then a box with
    Code:
    directory?
    I have tried everything in here.
    There is then a check box with something like:
    Code:
    plain rpm repository?
    I have tried with this checked and unchecked, pointing to the .iso, the unpacked iso, the suse directory within the unpacked iso, the suse/i586 directory within the unpack etc etc.
    I have now exhausted all I can think of.

    If I answer NO to the first question, the install aborts.

    At the install options menu, there is expert>config and >change config.

    Looking in >config I find that there is
    Code:
    install url:hd/name.iso?device=sdb1
    which AFAICS, is correct
    If I go >change config, I could alter the above.

    One thing always present is the ? in the path
    Code:
    hd:///name.iso?device=xxxxxxxxxxxxx
    Any ideas anyone?
    Should I submit a bug report?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •