Find the answer to your Linux question:
Results 1 to 2 of 2
I need some help with fail2ban on opensuse 11.2. Everything seems to be configured properly but it does not ban. I edited the jail.conf, snippet - Code: [ssh-iptables] enabled = ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User geese's Avatar
    Join Date
    Jan 2005
    Location
    Florida / Trinidad W.I.
    Posts
    287

    fail2ban not banning


    I need some help with fail2ban on opensuse 11.2.
    Everything seems to be configured properly but it does not ban.

    I edited the jail.conf, snippet -
    Code:
    [ssh-iptables]
    
    enabled  = false
    filter   = sshd 
    action   = iptables[name=SSH, port=ssh, protocol=tcp]
               sendmail-whois[name=SSH, dest=you@mail.com, sender=fail2ban@mail.com]
    #logpath  = /var/log/sshd.log                                                   
    logpath  = /var/log/messages                                                    
    maxretry = 5
    And when i run
    Code:
    fail2ban-regex /var/log/messages /etc/fail2ban/filter.d/sshd.conf
    I get "Success, the total number of match is 80"

    Yet it does not ban. I'm sure it has to be something simple. Can anyone help.

    Thanks, Geese.

  2. #2
    Linux User geese's Avatar
    Join Date
    Jan 2005
    Location
    Florida / Trinidad W.I.
    Posts
    287
    *sigh* I feel so stupid now. This has been buging for over a week but figured it out by looking at my own post. "enabled = false" has to be "enabled = true".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •