Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I installed Suse 10.1 on a Pentium III system this evening, but when I booted it into KDE for the first time, the desktop font is gigantic. I mean the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    7

    HUGE text on desktop (Suse10.1)


    I installed Suse 10.1 on a Pentium III system this evening, but when I booted it into KDE for the first time, the desktop font is gigantic. I mean the words "My Computer" fill the entire width of the screen! If I click on the green icon in the bottom left of the screen the resulting menus are so gigantic they cannot even be read! I cannot use the computer in this state and cannot think of a way to sort this. Obviously the installation has fouled up somewhere while installing fonts and/or video drivers. Can anyone suggest a way to sort this?

    UPDATE: Since posting this, I have rebooted into a different shell, unfortunately with the same HUGE text, but it has provided a command window with normal small text... so I can now enter any commands you can give me. I am rather new to Linux command language however, so it might be a tricky process.
    Last edited by TommyWylie; 11-22-2009 at 09:36 PM. Reason: update

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    How unusable is it? Can you open the control center (or type kcontrol in your terminal to open), I'm not sure where exactly it is but I think under Appearance->Fonts there will be an option to force DPI. Try changing the value to 96.

    Open try editing the file kdmrc
    Code:
    nano /opt/kde/share/config/kdm/kdmrc
    Look for the line starting ServerArgsLocal and append -dpi 96 to that line. It'll look something like
    Code:
    ServerArgsLocal=-nolisten tcp -dpi 96
    or try
    Code:
    xrandr --dpi 96

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    By the way , opensuse 10.1 reached end of life May 31st 2008 and is no longer supported. I highly recommend installing a current distro. (This may also solve your problem.)

  4. #4
    Just Joined!
    Join Date
    Nov 2009
    Posts
    7
    OK thanks reed9. I typed "nano /opt/kde/share/config/kdm/kdmrc" and the KDE console opened. I have a picture of it on my hard drive but I can't upload it as the upload box asks me for a URL. I got nowhere with the other methods you described.

  5. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    29
    As reed9 already mentioned, this version is not supported any longer, so you would be better off installing openSUSE 11.2.

    You could try the following:Boot to runlevel 3, by typing '3' at grub menu, then press 'Enter'. Log in, and then enter these commands

    su (to become root, enter root password when prompted)
    nano /opt/kde/share/config/kdm/kdmrc

    It is also possible that you need to reconfigure your graphics card settings. Again, from runlevel 3, as root, you could try

    sax2 -r (try to redetect your graphics card)

    or

    sax2 -r -m 0=vesa (to use basic vesa driver to get working desktop)

    Type 'init 5' when finished.

  6. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Were you able to edit the ServerArgsLocal line and restart? No effect? Oh, shoot, you might not be able to edit it. It needs to be opened as root, sorry
    Code:
    su -
    nano /opt/kde/share/config/kdm/kdmrc
    You can try booting into runlevel 3 (which means no GUI), and trying to force the dpi when starting the X server.

    Code:
    su -
    nano /etc/inittab
    Look for this line
    Code:
    # The default runlevel is defined here
    id:5:initdefault:
    Change the 5 to 3.
    Code:
    # The default runlevel is defined here
    id:3:initdefault:
    Reboot. (From the console reboot with
    Code:
    su -c 'reboot'
    When it starts, it will drop you to just a console login.
    After logging in as your user try
    Code:
    startx -- -dpi 96

  7. #7
    Linux Newbie
    Join Date
    Apr 2009
    Posts
    160
    Quote Originally Posted by deano_ferrari View Post

    You could try the following:Boot to runlevel 3, by typing '3' at grub menu, then press 'Enter'. Log in, and then enter these commands
    try getting to a virtual console by hitting CTRL+Fx key (x being 1-6)

    then as root type

    Code:
    init 3

  8. #8
    Just Joined!
    Join Date
    Nov 2009
    Posts
    7
    OK thanks guys I now have a desktop I can actually read! I wish I could show you what it looked like before... I took a photograph of it but can't upload it from my local machine as the site asks for a URL for the image.

    OK, now the adventure will start...!

  9. #9
    Just Joined!
    Join Date
    Nov 2009
    Posts
    7
    Spoke too soon. I was in failsafe mode, so I logged off and rebooted... and KDE came up with gigantic text again. I have had to reboot once more with the dpi 96 command. If I don't type startx -- -dpi 96 it gives me huge text. I am now in KDE with proper sized text. Is there anywhere in KDE to set the text size so this does not happen again?

  10. #10
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You should be able to set it from the KDE Control Center. Under Appearance and Themes -> Fonts.


Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •