Find the answer to your Linux question:
Results 1 to 4 of 4
As part of our Internet Technologies course we have to install apache on a unix machine and create our own private servers, however we are having problems setting up FTP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2009
    Posts
    2

    VSFTPD Problem


    As part of our Internet Technologies course we have to install apache on a unix machine and create our own private servers, however we are having problems setting up FTP to transfer the apache files, which will come from a Windows laptop with one running 7 and one running XP.

    I have looked on the internet for help and on this forum and have tried everything suggested but still havent had no luck.

    No matter what we do, everytime we try to start or restart vsftpd, it comes up with an error message with "failed" in red letters. (see below)

    # /etc/init.d/vsftpd start
    Starting vsftpd startproc: exit status of parent of /usr/sbin/vsftpd: 1
    failed
    If you require any more technical details then let me know.

    Thanks for any help in advance.

  2. #2
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Probably a configuration issue with /etc/vsftpd.conf. I can't really tell with that error message; it's kind of just saying something went wrong without saying what.

    I'll post my file (it gives access to my mounted public dirctory (you'll need to edit that) and to user directories with authentication)... maybe you can spot what's wrong with yours when contrasted against it.

    You might also get a more helpful clue from
    grep vsftpd /var/log/messages
    assuming you're using syslog_enable=yes. If not, then check your defined log location.
    Code:
    # Example config file /etc/vsftpd.conf
    # General Settings
    write_enable=YES
    dirmessage_enable=YES
    nopriv_user=ftpsecure
    ls_recurse_enable=YES
    
    # Local FTP user Settings
    local_enable=YES
    chroot_local_user=YES
    
    # Anonymus FTP user Settings
    anonymous_enable=YES
    anon_root=/mnt/hdb1
    anon_world_readable_only=YES
    
    # Log Settings
    syslog_enable=YES
    xferlog_enable=YES
    setproctitle_enable=YES
    
    # Transfer Settings
    connect_from_port_20=YES
    ascii_upload_enable=YES
    ascii_download_enable=YES
    
    # PAM setting. Do NOT change this unless you know what you do!
    pam_service_name=vsftpd
    listen=YES
    ssl_enable=NO
    pasv_min_port=30000
    pasv_max_port=30100

  3. #3
    Linux Newbie
    Join Date
    Apr 2009
    Posts
    160
    is vsftpd running and do you have the port open in suse firewall? Also /etc/hosts.deny denies access to everything by default so in /etc/hosts.allow you should allow your network's ip addresses.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2009
    Posts
    2
    Thanks for your help all, sorry for the late reply, it due to our lesson being only once a week. We did some research and managed to get it working by doing this:
    $ chkconfig vsftpd on
    $ /etc/init.d/xinetd start
    $ chkconfig xinetd on
    $ joe /etc/vsftpd.conf

    Then in vsftpd.conf we changed:
    write_enable = YES
    local_enable = YES
    chroot_local_user = NO


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •