Find the answer to your Linux question:
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
Holy grail, look what you have created! That takes a while to digest! But first, I didn't suggest to "shuffle" with disks. Only that your menu.lst isn't correct and could ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142

    Holy grail, look what you have created!
    That takes a while to digest!

    But first, I didn't suggest to "shuffle" with disks.
    Only that your menu.lst isn't correct and could be corrected.
    But now I feel that you were and are afraid to change this thing.
    You want to keep your partitions intact.
    However if you change anything in it, this will not change anything on those partitions.
    It's only a pointer to the correct partitions.

    When I gave it a quick look I wonder if windows2000 still works?
    Because I cannot find windows2000 as operating systems on any partition.
    I hope for you that I am not correct.
    But I still think that de menu.lst with pointing to the correct partition will do the thing.
    That means hd0 is sda, hd1 is sdb etc.
    Just try it as lostfarmer and I have suggested with GRUB and the command prompt.
    By doing so you cannot ruin anything.
    You can also boot in windows in this way, just type the command and right partition.
    In the end you have to change your menu.lst.
    But remember, if you want to eat a coconut you first have to crack it.

  2. #22
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Just looked through the output of your bootinfo_script. What a mess! As linuxforever says, you will not destroy any data/partitions by making changes in menu.lst files. If you have an Opensuse CD and/or SuperGrubDisk, you should be able to boot.

    At the beginning of the script output you can see that you have no bootloader in the master boot record of sda, which is your primary drive and has the largest number of partition on it and one would expect to have it set as first boot priority with something in the mbr?

    You have windows in the master boot record of sdb.

    You have Grub in the master boot record of sdc so that would be the drive you would need to set to first boot priority to boot with Grub stage1 in the mbr and it would have to be pointing to one of your Opensuse partitions, sdb2, sda7 or sda2.

    Grub 0.97 is installed in the MBR of /dev/sdc and looks on boot drive #3
    in partition #2 for /boot/grub/stage2 and /boot/grub/menu.lst.
    This could be problematic. Obviously from this scripts point of view, "boot drive #3" is NOT sdc as sdc only has xp and a vfat partition. Partition two of sda and sdb each have an Opensuse install but which one it is, I haven't a clue. Are you booting with the 11.2 Grub or 10.3? Whichever you are using, you could edit that menu.lst and put an entry for either Opensuse of "root (hd0,1) and then "root (hd1,1) trying each.

    I noticed that in your 11.2 menu.lst you have entries for 11.2 with same kernel pointing to (hd2,1) and another entry for (hd1,1). Have you tried each of these?

    If you look at the menu.lst entries for Opensuse 10.3 in its menu.lst and the menu.lst entries for Opensuse 11.2 in its menu.lst, you will see that the "Hitachi" disk isseen as (hd0), the Samsung HD501LJ... is (hd1) and the Samsung HD502HI... is (hd2). There are a lot of numbers at the end of the Samsung drive names hence the "....", I didn't care to copy.

    Maybe that will help you figure out which drive is which. You might have to take the drives out to look at them.

    I also noticed in your Opensuse 11.2 menu.lst file at the bottom of the output that you have map commands for windows. You should have your entry there pointing to the xp partition and edit its boot.ini file if necessary. I noticed in this file that your map commands are backwards, you have:

    Code:
    title windows 1
    map (hd1) (hd0)
    map (hd0) (hd1)
    rootnoverify (hd1,0)
    makeactive
    chainloader +1
    It should be:

    Code:
    title Windows XP
         rootnoverify (hd1,0)
         map (hd0)  (hd1)
         map (hd1)  (hd0)
         chainloader +1
    I've not seen the rootnoverify (hd1,0) after the map command, always before?

    Good Luck!

  3. #23
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142
    Yes yancek you are right!

    Grub 0.97 is installed in the MBR of /dev/sdc and looks on boot drive #3
    in partition #2 for /boot/grub/stage2 and /boot/grub/menu.lst.

    That means that the linux boot-loader is loaded in the MBR of sdc (pata-drive).
    But that he points to sdb where suse11.2 is installed, which means boot drive 3 is sdb.
    And here begins the mess!

    Further, the windows boot-loader is installed in the MBR of sdb.
    But the bootfiles are on sdc, boot.ini and ntldr, on which it should point.
    In that boot.ini file we see that the windows dual-boot manager has 3 options.
    One for xp and two for 2000.
    Remember that in windows the first partition is partition1.

    Normally if you install a second windows OS you get a windows dual-boot installed.
    And the files are boot.ini and ntldr which reside somewhere, but mostly on the first drive.
    Branisd says he can boot in windows, but he didn't say if it was xp, 2000 or a dual-boot.
    But there is no worry that data or files are missing.
    The only thing we don't know is if the windows2000 boot is still intact.
    I.e. what xp has done to the 2000 install.
    But even that should be repairable.

  4. #24
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    360
    branisd PMed me with some more info: At GRUB menu, OP went into command and use the tab function and compared results to fdisk.
    OP's results are:

    Code:
    hd0=/dev/sdc=PATA
    hd1=/dev/sda=(S)ATA_SAMSUNG_HD501LJ
    hd2=/dev/sdb=(S)ata-SAMSUNG_HD502HI
    1) Grub stage1 in sdc mbr does read stage2/menu.lst from sdb2.
    2) Suse 11.2 boot with no problem. (?)
    3) When Suse 10.3 is selected menu uses:
    root (hd1,1)
    configfile /boot/grub/menu.lst
    From menu.lst on sda2 if Suse 10.3 is selected (OP's first post) XP boots instead and XP selection results in NTLDR missing.

    The menu.lst on sda2 for Suse 10.3 does have an error due to hdd changes.

    title openSUSE 10.3 - 2.6.22.19-0.2 (default)
    root (hd1,1)
    kernel /boot/vmlinuz-2.6.22.19-0.2-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD501LJS0MUJDSP900048-part2 vga=0x31a resume=/dev/sdb5 splash=silent showopts
    initrd /boot/initrd-2.6.22.19-0.2-default
    The resume=/dev/sdb5 is wrong, it is pointing to a FAT32 partition and should be a swap. Due to 3 different swap partition I'm not sure if it matters which swap partition. Can try resume=/dev/sda5

    same error for: title Xen -- openSUSE 10.3 - 2.6.22.19-0.2

    for: title openSUSE 10.3 (/dev/sdc2)--can not make out why it is there.

    branisd- when you select from first menu.lst-
    {title openSUSE 10.3 - 2.6.22.19-0.2 (default) (/dev/sda2)} do you get the second menu.lst from sda2 ? Make sure of the answer. You may need to remove the timeout for the menu # timeout 8 .

    To get MS Windows working , if it is not, need to know what hdd as seen by grub has MS boot files {boot.ini, NTLDR} and if the first meun.lst or the 2 one ?

    Is sda3 and sda7 both /home or data partitions with no OS's ?
    Do you know why sda7 has a menu.lst on it ?

  5. #25
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    142
    Branisd could not post a reply here.
    He got a message "Can't post messages - limit is 15".

    I do not understand!

    So he did a question in linuxquestions.org.

Page 3 of 3 FirstFirst 1 2 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •