Find the answer to your Linux question:
Results 1 to 9 of 9
Within the last few weeks I've been experiencing problems with pages such as Facebook (which is actually, suprisingly very important as it may aswell be my diary), and Myspace (which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    5

    Unhappy Problems with websites, help!


    Within the last few weeks I've been experiencing problems with pages such as Facebook (which is actually, suprisingly very important as it may aswell be my diary), and Myspace (which I use for the purposes of Music studies).

    The problem is, is I can log into each of these, however I cannot actually DO anything;
    On facebook, I am limited to logging in, viewing and uploading pictures. However I cannot check my inbox, cannot change my status, tag or untag photos, accept or reject any kinds of requests, check my events, write to anyone (either in wall comments, threads, or inbox messages), amongst other things.

    This is very similar to my problems with Myspace- I can upload photos, view them, read comments and messages, send and accept friend requests, yet I cannot write to anyone in a comment or inbox, cannot post photo comments, amongst other problems.

    I find this very confusing as all was fine a matter of weeks ago.
    This may seem very unimportant but it's very frustrating!!

    I was wondering if anyone could possibly help me, or would have any idea as to what the problem is?

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You need to tell us a little more. Which browser which addons if any. Which version of Suse. Have you tried with different browser?

    Your post here seemed to work or are you using a different machine?````--

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    5
    not sure which version of suse it is, but i'll find out...
    i generally use firefox, but i did try my other two browsers (Konqueror and Epiphany), but had the same problems.

    No I'm using the same computer- which i don't understand because it's the same sort of idea as those two sites.
    the thing with facebook is that I CAN write in the box, i just cant send it

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Do you have an addon to FireFox like Noscript?? No Script blocks Scripting such as Javascript unless you say it is ok for that site. Some sites rely on scripting to proform certain function.

    See if there is a circle with a 'S' in it on the lower right of the browser window. If there is you have Noscript running. Also there may be a red circle with a slash in it. This indicates that scripts are blocked for that current page/site. If the read circle is off center it means that some scripts are blocked others are not. Click the circle and you will get a menu listing the source of all the scripts. You may allow some scripts and block others. Generally allowing just the website is enough to get the basic scripts working while still blocking scripts from ads or data collections systems such as google-analytics.com. Or you can just allow all of the page. In which case you no longer block any of the scripting sites.

  6. #5
    Just Joined!
    Join Date
    Dec 2009
    Posts
    5
    I'm not entirely sure....

    Just on the FB page now, and say that there is any 'S' there at all, and no red circle with a slash (as far as I can see anyway)- the only symbols visible are in the bottom right corner, showing that GreaseMonkey is enabled, and that Beagle indexing is disabled.

    Is there any other way which I can access the menu listing the source of all the scripts?

  7. #6
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Try deleting your user firefox profile.

    Backup first
    Code:
    cp -r ~/.mozilla/firefox/ ~/firefox_profile_backup
    Then remove
    Code:
    rm -r ~/.mozilla/firefox
    Restart firefox. This will delete all of your user settings, passwords, bookmarks, etc. and start firefox fresh.

  8. #7
    Just Joined!
    Join Date
    Dec 2009
    Posts
    5
    does not have the same result as when you use the 'clear private data' in the 'tools' drop-down at the top of the screen?

  9. #8
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Hmm rereading you say you also tried other browsers. So I guess this is not a FF problem after all since FF settings would not effect other browsers. Also since you don't have a S in a circle at the bottom right you do not have noscript installed anyway. Try turning Greasmonkey off see if that helps. But again this would not effect other browsers so not at all sure if this is a real solution. Maybe the sites in questions have upgraded to something that does not work in Linux?? Some MS specific scripting??

  10. #9
    Just Joined!
    Join Date
    Dec 2009
    Posts
    5
    okay well the thing is, is i'm not entirely sure exaclty as to what greasemonkey actually is!
    but i'll look into it later, and have a go at seeing what happenes when i turn it off, and i'll let you know what happens.
    yeah that's possible. Oh well, if nothing works then it doesn't matter too much, I'll hopefully be getting a mac pretty soon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •