Find the answer to your Linux question:
Results 1 to 9 of 9
I did autoinstallation of SuSe 9 using autoyast and its XML profile. After installation, I can't ping machines on local LAN by their hostnames whereas they can be pinged using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17

    SUSE 9: Cant ping machines on local LAN by host name


    I did autoinstallation of SuSe 9 using autoyast and its XML profile. After installation, I can't ping machines on local LAN by their hostnames whereas they can be pinged using their IPs. I can ping google.com by hostname and IP i.e. I can access internet without any trouble.
    Also, I can ping the SuSe machine from other Windows or Linux machines on LAN using its IP.

    Any help in this regard will be highly appreciated!
    thanks a lot...

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Are you running a DNS server? You would have to have your hostnames registered with your DNS server so that the names can be resolved. Some routers provide this functionality but not all.

  3. #3
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    Bigtomrodney,

    Yes there is a DNS server running on my local network. I did the same type of installation with SuSe 10 and it worked fine without any registrations etc.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    I got the root cause but not the correct solution... "/etc/resolv.conf" isnt getting modified by dhcpd service, it doesnt contain 'nameserver' and 'search' entries.

    Any solutions??

  6. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    You might want to have a look in YaST.

    Go to Yast > Network Settings > Hostname/DNS and see if you are setup to automatically update resolv.conf.

  7. #6
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    As I said earlier, I am doing an auto-install. I am preparing my XML profile using autoyast. Its networking section looks like this=>

    <networking>
    <dns>
    <dhcp_hostname config:type="boolean">true</dhcp_hostname>
    <dhcp_resolv config:type="boolean">true</dhcp_resolv>
    <domain>abc.com</domain>
    <hostname>suse-machine</hostname>
    </dns>
    <interfaces config:type="list">
    <interface>
    <bootproto>dhcp</bootproto>
    <device>eth0</device>
    <startmode>onboot</startmode>
    </interface>
    </interfaces>
    <modules config:type="list">
    <module_entry>
    <device>static-0</device>
    <module></module>
    <options></options>
    </module_entry>
    </modules>
    <routing>
    <ip_forward config:type="boolean">false</ip_forward>
    </routing>
    </networking>

    As you can see, I have set <dhcp_hostname> and <dhcp_resolv > fields as "true". 'abc.com' is a dummy domain name.
    Now, where I am going wrong??

  8. #7
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    another update...

    When I delete my old /etc/resolv.conf and restart dhcpcd daemon, then it does not recreate resolv.conf on the machine on which I carry autoinstall. But on the machine which I set up manually, resolv.conf is recreated if I restart dhcpcd.

    Any probable reasons??

  9. #8
    Just Joined!
    Join Date
    Oct 2009
    Posts
    17
    SOLVED!!

    I found the option in Yast where the entry 'modify_resolv_conf' in /etc/sysconfig/network/config is set to YES.

    This fixed the issue...

    Thanks a lot BigTomRodney for your help!!

  10. #9
    Just Joined!
    Join Date
    Dec 2009
    Posts
    1

    Hello

    That is so nice collection.Well after finding your this comment there is no need for any book reading search of last few years.I like your idea for distributing the books by years.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •