Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hey, I have just installed openSUSE intending to dual boot that and Ubuntu 9.04 but after doing so, the Grub2 menu won't recognise the Ubuntu partition. It knows it's there ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35

    Dual-boot openSUSE with Ubuntu 9.04


    Hey,

    I have just installed openSUSE intending to dual boot that and Ubuntu 9.04 but after doing so, the Grub2 menu won't recognise the Ubuntu partition.
    It knows it's there but when I click enter on Ubuntu, it takes me to an error 13, I think it was.

    I'm not too confident working with the Grub menus so I thought I should probably ask somewhere if someone else would be able to help me do this as I really don't want to ruin anything.

    If it helps, here is what is printed when I type in the console...
    Code:
    linux-liuw:/home/boris # fdisk -l
    
    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00002141
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1            3910       14267    83200635   83  Linux
    /dev/sda2           14268       14593     2618595    5  Extended
    /dev/sda3   *           1        1564    12562798+  83  Linux
    /dev/sda4            1565        3909    18836212+  83  Linux
    /dev/sda5           14268       14593     2618563+  82  Linux swap / Solaris
    
    Partition table entries are not in disk order
    and also...
    Code:
    linux-liuw:/home/boris # cat /boot/grub/menu.lst
    # Modified by YaST2. Last modification on Thu Dec 10 01:16:59 GMT 2009
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader
    
    default 0
    timeout 8
    ##YaST - generic_mbr
    gfxmenu (hd0,2)/boot/message
    ##YaST - activate
    
    ###Don't change this comment - YaST2 identifier: Original name: linux###
    title openSUSE 11.2
        root (hd0,2)
        kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_HM121HJ_S1M2JD0S321303-part3 resume=/dev/disk/by-id/ata-SAMSUNG_HM121HJ_S1M2JD0S321303-part5 splash=silent quiet showopts vga=0x317
        initrd /boot/initrd-2.6.31.5-0.1-default
    
    ###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)###
    title  Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)
        root (hd0,1)
        configfile /boot/grub/menu.lst
    
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###
    title Failsafe -- openSUSE 11.2
        root (hd0,2)
        kernel /boot/vmlinuz-2.6.31.5-0.1-default root=/dev/disk/by-id/ata-SAMSUNG_HM121HJ_S1M2JD0S321303-part3 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x317
        initrd /boot/initrd-2.6.31.5-0.1-default
    I'm wanting to learn more about Linux and I do my best but this is all over my head at the minute.

    Would someone be able to point me in the right direction?

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Trouble is there are now two different versions of grub. The New grub2 is used by Ubuntu and the old grub is still used by Suse. I have not done this (I don't run Ubuntu) but as I understand it when installing Suse on a machine that has Ubuntu it is best to install grub to a partition and let grub2 control things. Not sure about the fix you got into and how to correct it. Maybe booting to the Ubuntu install disk and doing a repair. As I understand it the grub2 should pick up the Suse partition.

  3. #3
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    341
    From what I can see in your menu.lst file, it looks as though Ubuntu entry should be (hd0,0).
    Can you mount the Ubuntu partition from inside opensuse and print the contents of Ubuntu's /etc/fstab file?
    We might be able to help more if we could see that.
    Pete

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35
    Hey.
    Thank you both for you replies.
    Here is the contents of the /etc/fstab file
    # /etc/fstab: static file system information.
    #
    # Use 'vol_id --uuid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # / was on /dev/sda1 during installation
    UUID=7c9d3f89-10bc-44e6-acd5-b6c5b4aa6d46 / ext3 relatime,errors=remount-ro 0 1
    # swap was on /dev/sda5 during installation
    UUID=e0f6653e-0900-45ec-bf18-a81a023e05be none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    # edit

    I just tried the booting into Ubuntu again just to see if I gave the right details here and I was partly wrong. It gives an error 15 but this is what it says anyway.

    Code:
     'Booting Ubuntu 9.04, kernel 2.6.28-1-generic
    kernel /boot/vmlinuz-2.6.28-generic root=UUID-7c9d3f89-10bc-44e6-acd5-b6c5-4r96d46 ro quiet splash
    
    File not found...
    
    Press any key to continue

  6. #5
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I have Ubuntu 9.04 and Opensuse 11.2 installed and both use Grub Legacy. Ubuntu 9.10 uses Grub2. Where did the Grub2 come from? Did you install It or do you have Ubuntu 9.10?

    You should be able to boot Ubuntu by changing the entry to: root (hd0,0) for Ubuntu.
    Or you could mount Ubuntu from Opensuse and navigate to the /boot/grub/menu.lst file and copy the first Ubuntu entry to the Opensuse menu.lst.

    If you do have Grub2 installed, this won't work.

  7. #6
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    341
    I just tried the booting into Ubuntu again just to see if I gave the right details here and I was partly wrong. It gives an error 15 but this is what it says anyway.

    Code:

    'Booting Ubuntu 9.04, kernel 2.6.28-1-generic
    kernel /boot/vmlinuz-2.6.28-generic root=UUID-7c9d3f89-10bc-44e6-acd5-b6c5-4r96d46 ro quiet splash

    File not found...

    Press any key to continue
    The line above I assume is in Ubuntu's /etc/menulst. It should read
    Code:
    kernel /boot/vmlinuz-2.6.28-11-generic ....
    Pete

  8. #7
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35
    Quote Originally Posted by yancek View Post
    I have Ubuntu 9.04 and Opensuse 11.2 installed and both use Grub Legacy. Ubuntu 9.10 uses Grub2. Where did the Grub2 come from? Did you install It or do you have Ubuntu 9.10?

    You should be able to boot Ubuntu by changing the entry to: root (hd0,0) for Ubuntu.
    Or you could mount Ubuntu from Opensuse and navigate to the /boot/grub/menu.lst file and copy the first Ubuntu entry to the Opensuse menu.lst.

    If you do have Grub2 installed, this won't work.
    I tried that. And Grub2 came from installing opensuse 11.2

    Quote Originally Posted by peteh View Post
    The line above I assume is in Ubuntu's /etc/menulst. It should read
    Code:
    kernel /boot/vmlinuz-2.6.28-11-generic ....
    That line is what appears when I try booting Ubuntu.

  9. #8
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    341
    I couldn't find the edit button for the last reply.
    The line I mentioned should be followed by
    Code:
    initrd /boot/initrd.img-2.6.28-11-generic
    And that assumes you haven't updated your kernel in ubuntu.
    Pete

  10. #9
    Just Joined!
    Join Date
    Dec 2008
    Posts
    35
    Quote Originally Posted by peteh View Post
    I couldn't find the edit button for the last reply.
    The line I mentioned should be followed by
    Code:
    initrd /boot/initrd.img-2.6.28-11-generic
    And that assumes you haven't updated your kernel in ubuntu.
    So should I put
    kernel /boot/vmlinuz-2.6.28-11-generic
    initrd /boot/initrd.img-2.6.28-11-generic
    in the /boot/grub/menu.lst under Ubuntu?

    And no, I haven't updated in a few months - only recently got the internet back.

  11. #10
    Linux User peteh's Avatar
    Join Date
    Oct 2006
    Location
    UK
    Posts
    341
    ###Don't change this comment - YaST2 identifier: Original name: Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)###
    title Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)
    root (hd0,1)
    configfile /boot/grub/menu.lst
    This entry is in /boot/grub/menu.lst in opensuse. Change root (hd0,1) to root (hd0,0).
    Delete the line beginning 'configfile ...' and replace it with
    Code:
    kernel /boot/vmlinuz-2.6.28-11-generic root=UUID-7c9d3f89-10bc-44e6-acd5-b6c5-4r96d46 ro quiet splash
    initrd /boot/initrd.img-2.6.28-11-generic
    Then let us know if that works.
    You might want to copy and paste those lines to get them right.
    The whole entry should then look like this
    Code:
    ###Don't change this comment - YaST2 identifier: Original name:  Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)###
    title  Ubuntu 9.04, kernel 2.6.28-11-generic (/dev/sda1)
        root (hd0,0)
    kernel /boot/vmlinuz-2.6.28-11-generic root=UUID-7c9d3f89-10bc-44e6-acd5-b6c5-4r96d46 ro quiet splash
    initrd /boot/initrd.img-2.6.28-11-generic
    Pete

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •