Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 35
I have a new Dell Studio laptop and has loaded with correct 64 bit suse 11.2. However, I have found that the wireless is not detecting any AP's at all. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    17

    Unhappy Wireless Driver Issues


    I have a new Dell Studio laptop and has loaded with correct 64 bit suse 11.2.
    However, I have found that the wireless is not detecting any AP's at all. This came preloaded with Windows 7 and on the set up it did detect AP's. I obviously replaced Windows (with a new hard drive) alsowhile trying to work out what was going on I loaded a live cd of Ubantu 9.1 and it came up with an interesting suggestion - stating that the driver for my wireless card was locked and that I should unlock it, however one of the drivers did not unlock and the other one it downloaded and installed the drivers successfully, this lasted for all of 10 seconds before it stated that it was locked again.
    I have been through the diagnostic sticky and followed the steps and I am even more confused now as the driver seems to be loading the firmware and in the hardware information the card is successfully detected and it says the driver is active.
    The device is Broadcom 4322 WLAN.
    The relevant section in the boot.msg states the following:-
    b43-phy0: Broadcom 4322 WLAN found (core revision 16)
    <6>[ 5.357111] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[17] MMIO=[fc600000-fc6007ff] Max Packet=[2048] IR/IT contexts=[4/4]
    <6>[ 5.362400] sdhci-pci 0000:09:01.1: SDHCI controller found [1180:0822] (rev 22)
    <6>[ 5.362444] sdhci-pci 0000:09:01.1: PCI INT B -> GSI 18 (level, low) -> IRQ 18
    <6>[ 5.364579] Registered led device: mmc0::
    <6>[ 5.365846] mmc0: SDHCI controller on PCI [0000:09:01.1] using DMA
    <3>[ 5.367430] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 8, Type 4, Revision 4)
    <4>[ 5.367469] b43: probe of ssb0:0 failed with error -95
    <6>[ 5.367485] Broadcom 43xx driver loaded [ Features: PML, Firmware-ID: FW13 ]
    <6>[ 5.382449] ACPI: AC Adapter [ADP1] (off-line)

    The kernal driver in hardware information is ssb and states the wireless controller as :
    BCM4322 802.11a/b/g/n wireless LAN controller


    I have been told elsewhere to download the "Broadcom wl" package - which I have done but have been unable to install it. I had heard it involves kernel changes which is way way beyond me - have tried through YaST

    Can anyone help me in a sort of "idiot proof way" - pretty please

  2. #2
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Yes, you need the broadcom-wl driver. You'll need to enable the Packman repository first.

    Then
    Code:
    sudo zypper install broadcom-wl broadcom-wl-kmp-$kernelflavor
    Where $kernelflavor is your type of kernel. I'm not too familiar with opensuse, but presumably that would be broadcom-wl-kmp-default or broadcom-wl-kmp-desktop.

    You should be able to figure out the kernel looking at the output of
    Code:
    uname -r
    or
    Code:
    uname -a

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    17
    I do not have any internet access on the laptop in question - even the ethernet drivers are unusable.

    I can download and put onto a memory stick and possibly install through yaST - however, if it is a tarball I am not sure how to compile/install from this.

  4. #4
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Have you tried to set up your wired connection via Yast??You really need that working first.

  5. #5
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    You can download the files from here. They are rpm files, not source files.

    Put them on a USB stick, transfer them over to your home directory and install with
    Code:
    sudo rpm -Uvh broadcom-wl-5.10.91.9.3-6.pm.7.3.x86_64.rpm
    sudo rpm -Uvh broadcom-wl-kmp-default-5.10.91.9.3_2.6.31.12_0.1-6.pm.7.3.x86_64.rpm
    Assuming broadcom-wl-kmp-default is the correct package for your kernel.

    I am not positive that there are no other dependencies necessary, however. I know there are in Ubuntu, but I'm not very familiar with opensuse.

  6. #6
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Suse 11.2 defaults to desktop kernel unless told otherwise at the install. Just make sure that the kernel types match the one you are running.

  7. #7
    Just Joined!
    Join Date
    Feb 2010
    Posts
    17
    Hi
    These two packages apprear to have installed successfully - however, I can still not scan for any AP's - no other dependancies cropped up during installation.

    Getting seriously desperate !!!

  8. #8
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Once the driver is installed, you'll need to load the module. In theory, it should automatically be detected and load at boot. Check the output of
    Code:
    lsmod | grep wl
    to see if it's loaded. No output means it isn't.

    To load by hand do
    Code:
    sudo modprobe wl
    sudo depmod -a
    You'll also need to make sure the b43 driver is not loaded
    Code:
    sudo ifconfig wlan0 down
    sudo modprobe -r b43
    And if it continues to load at boot, blacklist it
    Code:
    echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Or otherwise edit the file /etc/modprobe.d/blacklist.conf and append the line blacklist b43 to the end.

    Bring the interface back up if needed
    Code:
    sudo ifconfig eth1 up
    Note that the wl driver usually names the interface eth1 and the b43 driver names it wlan0. It's possible this is not always the case. Check the interface names with
    Code:
    iwconfig

  9. #9
    Just Joined!
    Join Date
    Feb 2010
    Posts
    17
    When doing the sudo modprobe wl command it return a fatel error - module wl not found. However, this installed quite successfully with yaST and I have noticed 2 extra options have been added to the boot loader.

  10. #10
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    If the module wasn't found, then it didn't get installed properly. Maybe we should work on getting the wired connection up and make this easier.

    What is your ethernet card? Post the output of
    Code:
    lspci -vnn
    or find the ethernet card in that output and post that.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •