Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
So after I installed the ATI Radeon 3400 series video card in my machine, the Xserver cant start! after it loads, it takes me to the init 3. When I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6

    SUSE ATI Video Card, Monitors go blank for X-Windows PLEASE HELP


    So after I installed the ATI Radeon 3400 series video card in my machine, the Xserver cant start! after it loads, it takes me to the init 3. When I tried startx, the screens either go blank or doesnt let me.

    I tried to install everything following this website:

    w w w .yolinux.com/TUTORIALS/LinuxAndDualMonitors.html

    I wanted dual monitors but now I cant even get one. The xwindows doesnt appear.

    Things I tried:
    1. Deleted the xorg.conf and reconfigured (didnt work).
    2. sax2 -r -m 0=versa (didnt work)
    3. reconfigured the ATI radeon driver from init 3 (didnt work)
    4. copy and paste the oold version of xorg.conf (didnt work)
    5. tried to run set apt or dpkg-reconfigure command (commands not found)
    6. tried xconfig and prompt the best I coudl (didnt work).
    7. aticonfig commands (As shown in website) (also didnt work)

    Please anything else I can try?
    I have the live CD to run it from there but I dont know what to do once I get to the terminal.

    Is there any way I can revert to previous configuration since the ATI driver gives me some problems? Like a restore function in windows?

    Can someone explain how or what files I should change for the X-server to run properly (is there any other file than xorg.conf?....)

    PLease anything any clue will be greatly appreciate, I spent one entire day trying to figure it out.

    The monitors I have:
    2009W Dell Monitor
    1398 Dell Monitor (I wan to get the dual exntended monitor but it seems to gave me only the mirror image, thats why I tried to reconfigure the video card)

    VideoCard:
    ATI HD Radeon Mobile 3400 Series

    Computer:
    Dell Optiplex 680 (i believe) with SUSE 11.26 and x86_64 bit

    Or if you can send me the xorg.conf file ...then it will be great!!
    Thank you in advance.

  2. #2
    Just Joined! eTech97's Avatar
    Join Date
    Jul 2008
    Location
    Winnipeg, Canada
    Posts
    58

    ATI Graphics Problem

    Quote Originally Posted by Drigomaniac View Post
    So after I installed the ATI Radeon 3400 series video card in my machine, the Xserver cant start! after it loads, it takes me to the init 3. When I tried startx, the screens either go blank or doesnt let me.

    I tried to install everything following this website:

    w w w .yolinux.com/TUTORIALS/LinuxAndDualMonitors.html

    I wanted dual monitors but now I cant even get one. The xwindows doesnt appear.

    Things I tried:
    1. Deleted the xorg.conf and reconfigured (didnt work).
    2. sax2 -r -m 0=versa (didnt work)
    3. reconfigured the ATI radeon driver from init 3 (didnt work)
    4. copy and paste the oold version of xorg.conf (didnt work)
    5. tried to run set apt or dpkg-reconfigure command (commands not found)
    6. tried xconfig and prompt the best I coudl (didnt work).
    7. aticonfig commands (As shown in website) (also didnt work)

    Please anything else I can try?
    I have the live CD to run it from there but I dont know what to do once I get to the terminal.

    Is there any way I can revert to previous configuration since the ATI driver gives me some problems? Like a restore function in windows?

    Can someone explain how or what files I should change for the X-server to run properly (is there any other file than xorg.conf?....)

    PLease anything any clue will be greatly appreciate, I spent one entire day trying to figure it out.

    The monitors I have:
    2009W Dell Monitor
    1398 Dell Monitor (I wan to get the dual exntended monitor but it seems to gave me only the mirror image, thats why I tried to reconfigure the video card)

    VideoCard:
    ATI HD Radeon Mobile 3400 Series

    Computer:
    Dell Optiplex 680 (i believe) with SUSE 11.26 and x86_64 bit

    Or if you can send me the xorg.conf file ...then it will be great!!
    Thank you in advance.

    Here is a Guide to troubleshooting Graphics Problems on openSUSE 11.2 from the openSUSE Forums openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

    I hope that this helps you out

    Cheers!
    Tom

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You should have bought NVIDIA. ATI is a major problem on 11.2

    To get started log into the terminal as root

    type sax2 -r -m 0=vesa (note that is a zero not a upper case o)

    type
    init 5

    to start the GUI

    You can then install the proprietary driver and you should be ok

    or try one of the radion drivers as listed in link above

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    tried that (and yes i know its a 0) but still the monitors go blank when I start the GUI (if it starts since I made some many changes....) Thank though!

  6. #5
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    I would suggest running sax2 right from the command line as is. Set your video mode to something any monitor can handle, say 1024x768.

    My guess is that the video card is sending a signal outside the monitor's limit, it can be resolution, frequency range, or refresh rate, any one will do it. Set a low resolution first, and if it tests okay, you can slowly work up with the manual configuration until you get one you like and does the job.

  7. #6
    Linux Guru
    Join Date
    Jul 2004
    Posts
    4,593
    You should look at your Xorg log file. It will tell you exactly what the problem is. This command will bring it up on a terminal on Ubuntu, it should work for Suse too.
    Code:
    cat /var/log/Xorg.0.log | less
    The 'less' pipe allows you to scroll down the log using the enter or up/down arrow keys. Look for any errors, they are preceded with a (EE).
    Please do not send Private Messages to me with requests for help. I will not reply.

  8. #7
    Just Joined!
    Join Date
    Feb 2010
    Posts
    6
    D-cat:
    sax2 doesnt work. When I run it...it goes to the blank window and i need to restart.... :'(

    waterhead:
    according to the log file... many /usr/share/fonts do not exist.....
    besides this...its a very big file.... any clues?
    theres a lot of fglrx(0): lines

  9. #8
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    The font lines are normal. What was the old card? had you installed the propritary drivers. Did you already have a /etc/X11/xorg.conf file??

    if so try renaming it and see if it works without it. If not rename back and edit it to use vesa

  10. #9
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    sax2 doesnt work. When I run it...it goes to the blank window and i need to restart.... :'(
    Try navigating in via typing yast on the command line. then go to Hardware -> Graphics Card and Monitor. When entered in text mode, it's suppost to stay in text mode until it's time to test the configuration. If it's still too stuborn and goes into blank screen again, try sax2 -l (that's SAX2 -L) to force low res mode during configuration.

    From the blank screen, assuming the system isn't actually locked hard, you should be able to pull back out with
    [Ctrl + Alt + BackSpace] (might have to do it a couple times). That's the hotkey to abort the X server, at least it used to be.

  11. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Just rename /etc/X11/xorg.conf file ( if it exists ) and execute sax2 -r -m 0=vesa command again.
    In case it doesn't work, create xorg.conf file manually with Generic Settings.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •