Find the answer to your Linux question:
Results 1 to 6 of 6
I'm setting up a fresh install of opensuse 11.2 and run into a problem setting up Samba. I've setup (using smb4k)the workgroup and set the firewall to allow samba client ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    55

    Samba Setup Problem


    I'm setting up a fresh install of opensuse 11.2 and run into a problem setting up Samba. I've setup (using smb4k)the workgroup and set the firewall to allow samba client and server, and now I can click on the workgroup and see all the other machines but I can't view their shared files. When I click on any of them I get the hourglass for a few seconds then nothing. I'm guessing theres more I need to setup?

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    In my experience this is almost always a user error....you just missed something simple somewhere. You do have files in the shared folders right? No password login? Are the Win machines setup for file/print sharing? Yes, these are obvious questions, but like I said, I think you are close but just missed something small. Can you post your smb.conf file? Maybe someone will spot something.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    I've always found the the config file generated by Yast setup and other tools are too complicated and have never worked for me. I always do the config by hand.

    Here is a good place to start.
    Samba and Suse: HowTo Set up an openSUSE-Windows Home Office LAN/Network. Versions 11.x

    Pay attention to the firewall configuration.

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    55
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2009-10-27
    [global]
    workgroup = MSHOME
    passdb backend = tdbsam
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = No
    idmap gid = 10000-20000
    idmap uid = 10000-20000
    security = domain
    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    browseable = No
    read only = No
    inherit acls = Yes
    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

  5. #5
    Just Joined!
    Join Date
    Oct 2006
    Posts
    55

    Fixed

    I found it....I was missing the following 2 lines in smb.conf:

    netbios name = linuxbox
    name resolve order = bcast host lmhosts wins

  6. #6
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Good show.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •