Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I have one Linux PC installed with Suse 11.1. In this I have created three users to get access. Users able access their login from Windows PC via some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2009
    Posts
    15

    How to restrict users open session via XDMCP(Xmings XLaunch) from Windows PC


    Hi,
    I have one Linux PC installed with Suse 11.1. In this I have created three users to get access.
    Users able access their login from Windows PC via some utilities.
    1. Putty
    2. Xming
    Users able login using both. With Putty there is no GUI. But with Xmings XLaunch they are able to get similar session as Linux Host PC. At this point of time the host linux PC will become too slow in perfarmance.
    Can any one tell how to retrict the users not to open similar session by enablin/disabling some setting in Linux PC?

    Thanks.
    Ptr

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    71
    Hi emperor410, i dont seem to understand your problem cause, whether its putty or Xmings XLaunch the cause of the slow speed, but i certainly think is Xmings XLaunch, therefore i don't know whether this will help but its worth a try.
    according to straightrunning, Xmings XLaunch uses port 177/UDP, however you can prove that by doing
    #ps aux |grep xmings
    Anyway i was think that maybe try blocking that port in iptables, ie.
    #iptables -A INPUT -p tcp --dport 177 -j DROP

    am not good in iptables but i hope that helps, it will block any one trying to access that port, that includes you untill you allow them.
    Let us know if works

    Cheers

  3. #3
    Just Joined!
    Join Date
    Aug 2009
    Posts
    15
    Hi Robin_bga,
    The issue is with Xmings XLaunch.
    If I try to use #ps aux |grep xmings at root login, I am getting below
    root 4624 0.0 0.0 2260 680 pts/1 S+ 11:09 0:00 grep xmings
    In that which is the port number? numbers in 4624, 680 places are changing and 2260 is not changed if I check for some duration of time.
    Please clarify.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •