Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I have have some trouble with my ip adress. It disappears over night. I leave my modem turned on, which I understand is better. Any way. when i want to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2010
    Posts
    31

    Red face suse 11.2 looses ip adress


    I have have some trouble with my ip adress. It disappears over night. I leave my modem turned on, which I understand is better. Any way. when i want to use my computer I first have to reconfigure with yast. And then call my provider an have him reset my connection. He sayes that he can ping my computer sending/receiving. Then he resets my connection and i run configuration and restarts my browser and everything works fine\( and don\'t I love that\) Anybody knows what my bug is. or at least a hint would be fine.

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Sounds like a dhcp problem. Check that you have dhcp configured properly. Configure it in Yast.

    What kind of connection is it? is there a switch or router in the mix?

  3. #3
    Just Joined!
    Join Date
    Feb 2010
    Posts
    31
    It could might be the dhcp. I have changed the MTU to 1500 (Ethernet, DSL broadband) Were nothing in the drop down before changes.
    Cant give you any feedback before it crashes.

    I use Motorola 5100 cable straight on
    RTL-8139/8139C/8139C+ chipset


  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,746
    So, you are using a DSL modem connected directly to the computer? I assume you are getting a DHCP address and have not been assigned a static address (usually costs more). In that case, most ISP's will expire a DHCP address after some period of time, which is usually one or two days. That is what is probably happening to you. The fix for that is to connect the modem to a router that can deal with the address change, and you can use a local static address (NATed) that won't change.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    or just kill and rerun dhcpcd (as root). It has a similar effect to release and renew. I'm having nightmare flashbacks now of unreliable public WiFi connections...

  7. #6
    Just Joined!
    Join Date
    Feb 2007
    Posts
    7
    If he says, he can ping your computer, then you still have your IP address and it is there. It might be the DNS address on your computer or the DNS server at your provider is not functioning. My ISP sometimes has this issue, that a DNS server is just not translating domain names to IP addresses. To check if this is the issue, when you have it working as it should, get an IP address of some domain, you usually use and type it in your browser directly as IP, not domain name. Or try to ping it. save your results and when you do not have it working as it should anymore, then do the same thing. If the page loads and ping works, then it is the DNS fault.

    I am not sure, if this is the ISP is changing the DNS servers internally and somehow it does not get to your computer or your computer somehow does not accept the message.

  8. #7
    Linux Newbie previso's Avatar
    Join Date
    Jan 2010
    Location
    SC
    Posts
    116
    My guess is that you do not have the service set up to start automatically at boot. Hence no address when you come back after shutdown.
    Start/Applications/System/Administrator Settings/Network Devices/Network/RTL-8139
    Edit/General/At boot time
    /Address/ (either DHCP or static 192.168.2.2 for example with netmask 255.255.255.0 and host local)

  9. #8
    Just Joined!
    Join Date
    Feb 2010
    Posts
    31
    First, thank you everybody.

    I was in great doubt about the boot configuration. But i haven't changed that. It still starts up at boot. I will try to ping when it crashes and try out the dhcpcd command.

    Thanks

  10. #9
    Just Joined!
    Join Date
    Feb 2009
    Posts
    2
    Quote Originally Posted by Neological View Post
    First, thank you everybody.

    I was in great doubt about the boot configuration. But i haven't changed that. It still starts up at boot. I will try to ping when it crashes and try out the dhcpcd command.

    Thanks

    Even, I have had the similar problems as faced by you... Although, I am using Red Hat Enterprise Linux 5.0, in which the settings of my Ethernet card got changed automatically. I had used a static IP address on my Ethernet card, but after turning off my PC (not by rebooting), the static IP disappeared and it starts searching for dhcp server. Finally, to overcome this problem, I had run the following command: -

    #chattr +iua /etc/sysconfig/network-scripts/ifcfg-eth0

    where ifcfg-eth0 is the file, in which the configuration settings of Ethernet card is kept. I don't know where it would be in case of SuSE. Therefore, find the file, containing the IP configuration and lock it using chattr. After that, there would be no changes in the configuration. Please do give me a feedback on this. Thanks

  11. #10
    Linux Newbie previso's Avatar
    Join Date
    Jan 2010
    Location
    SC
    Posts
    116

    Question

    On Suse 11.2 the configuration file is

    /etc/sysconfig/network/ifcfg-eth0

    The file /etc/sysconfig/network/dhcp provides some hints on how to configure ifcfg-eth0

    Additionally, a cheap network router between the cable modem and the computer will handle the ip for you. Netgear can assign the address permantly (Linksys has always been a pain for me).
    Last edited by previso; 02-23-2010 at 02:55 PM. Reason: Spellcheck

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •