Find the answer to your Linux question:
Results 1 to 6 of 6
OpenSuse 11.2 has serious issue with audio. This happens on several computers, not just one. One one computer, sometimes it works when I reconfigure the audio hardware, then it stops ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    55

    OpenSuse 11.2 Audio Mute Issue


    OpenSuse 11.2 has serious issue with audio. This happens on several computers, not just one. One one computer, sometimes it works when I reconfigure the audio hardware, then it stops working, and I have to reconfigure it. Sometimes reconfigure doesn't even work.

    Then I found out that the volume widget doesn't work well. It can mute the audio, but it doesn't un-mute it. To fix the issue, I have to unmute it there, then use the command "gamix" to also unmute the speakers for it to work.

    The audio volume widget also doesn't go away when click on it mute/unmute, or change volume. To close it, I have to click on the Mixer button, then close the Mixer window. This is just unacceptable behavior.

  2. #2
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    KDE or Gnome?

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    i use kde. i uninstalled plasma on my box and all my audio problems disappeared. its worth a shot.
    linux user # 503963

  4. #4
    Just Joined!
    Join Date
    Oct 2007
    Posts
    55

    Kde

    Quote Originally Posted by gogalthorp View Post
    KDE or Gnome?
    KDE. I think I have plasma desktop. There is a setting when I click on the slider widget on the desktop, it has various items such as "Add Widgets", "Lock Widgets", "Configure Plasma". I clicked on the "Configure Plasma", and there is a small dialog shows up. I just assume my desktop is plasma enabled.

    Actually, I edit the Desktop effects in the Configure Desktop, and it turns it off. So, plasma is on, just the effects are off. I turned it on and the looks change a bit. The volume control now goes away when clicking on the volume icon again.

    It seems much slower for the desktop though. So, this is still a bug when turn off the desktop effect.

    The mute issue is still there.

  5. #5
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    actually the exact package was pulseaudio. that was what was killing me.
    linux user # 503963

  6. #6
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Yeah, I was just going to mention PulseAudio. It's performance varies with various cards. I'd just get rid of it and run straight ALSA and use Arts for the audio server (classic KDE). It's designed for Gnome anyway, and even then isn't known for consistent stable performance.

    Some apps will puke if libpulse.so isn't found, even if you don't use it, so keep that library and kill everything else. It was a bit of a fight against the package manager for me (11.1) but I got it to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •