Find the answer to your Linux question:
Results 1 to 2 of 2
When I plugin a 2nd monitor, the display settings in Configure Desktop allows me to change the display mode to single expanded screen versus duplicate desktop. However, after restart the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    55

    OpenSuse 11.2 Does Not Remember Display Settings


    When I plugin a 2nd monitor, the display settings in Configure Desktop allows me to change the display mode to single expanded screen versus duplicate desktop.

    However, after restart the computer, I have to do that again. I can understand that if I un-plug the 2nd monitor, it should intelligently switch to a single screen mode. But if I don't, it should remember it.

    Make the matter worse, if I am in single span screen mode (1 desktop on 2 monitors), and I unplug the monitor while the computer is running, it would not know how to switch back, even in the Display settings of Configure Desktop saying it's in the single monitor mode. This means application and mouse can freely be pushed way over that area of the screen (hidden).

    I write free software too, and I don't let obvious bugs like this creep into a major distribution like OpenSuse 11.2. It just gives a bad image for OpenSuse and open source in general.

  2. #2
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626
    i've had the same problems since 10.2, i just roll with it. when i boot, i keep my second monitor off until the nvidia driver loads. if i don't my fonts are tiny, and i have to reboot the X server, with monitor off of course.

    i think its a matter of just restarting your x server (ctrl+alt+backspace) when you make changes like that. if yours makes an annoying beep, be sure you modify the following line from /etc/X11/xorg.conf

    Code:
    option ZapWarning "on"
    change it to off. for me it was like a shotgun blast to the ears everytime i'd reboot the X server.
    linux user # 503963

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •