Find the answer to your Linux question:
Results 1 to 4 of 4
I am trying to install Oracle Application Server 10.3 on Suse Enterprise Desktop inux 10 .I am not able t o go past the software requirement stage as I am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3

    Arrow Suse Enterprose Desktop 10 -need to install Oracle Application Server 10.3


    I am trying to install Oracle Application Server 10.3 on Suse Enterprise Desktop inux 10 .I am not able t
    o go past the software requirement stage as I am unable to install the package for gnome-libs-1.4.1.7-671.1
    gnome-libs-devel-1.4.1.7-671.1
    sysstat-5.0.1-35.1.
    The following are the output I get when I try to install each of them.
    linux-d6go:~ # rpm -i /home/aravindh/Desktop/gnome-libs-1.4.2-18.3.i586.rpm
    warning: /home/aravindh/Desktop/gnome-libs-1.4.2-18.3.i586.rpm: Header V3 DSA signature: NOKEY, key ID 629ff0c2
    error: Failed dependencies:
    libIIOP.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libORBit.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libORBitCosNaming.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libORBitutil.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libc.so.6(GLIBC_2.7) is needed by gnome-libs-1.4.2-18.3.i586
    libdb-4.5.so is needed by gnome-libs-1.4.2-18.3.i586
    libxcb-xlib.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libxcb.so.1 is needed by gnome-libs-1.4.2-18.3.i586
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gnome-libs-1.4.2-18.3.i586linux-d6go:~ # rpm -i /home/aravindh/Desktop/gnome-libs-devel-1.4.2-18.3.i586.rpm
    warning: /home/aravindh/Desktop/gnome-libs-devel-1.4.2-18.3.i586.rpm: Header V3 DSA signature: NOKEY, key ID 629ff0c2
    error: Failed dependencies:
    gnome-libs = 1.4.2 is needed by gnome-libs-devel-1.4.2-18.3.i586
    gxmhtml = 1.4.2 is needed by gnome-libs-devel-1.4.2-18.3.i586
    orbit-devel is needed by gnome-libs-devel-1.4.2-18.3.i586
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gnome-libs-devel-1.4.2-18.3.i586
    linux-d6go:~ # rpm -i /home/aravindh/Desktop/orbit-0.5.17-446.44.i586.rpm
    warning: /home/aravindh/Desktop/orbit-0.5.17-446.44.i586.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 3dbdc284
    error: Failed dependencies:
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by orbit-0.5.17-446.44.i586

    I am not able to download the rpmlib as well.
    If someone would help me in this,it would be really appreciated.Plase help me.Thank uou in advance

  2. #2
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3

    Unhappy Please assit me......

    After struggling for the whole day,finally I have come to this point

    linux-d6go:~ # rpm -i /home/aravindh/Desktop/gnome-libs-1.4.2-18.3.i586.rpm
    warning: /home/aravindh/Desktop/gnome-libs-1.4.2-18.3.i586.rpm: Header V3 DSA signature: NOKEY, key ID 629ff0c2
    error: Failed dependencies:
    libc.so.6(GLIBC_2.7) is needed by gnome-libs-1.4.2-18.3.i586
    libdb-4.5.so is needed by gnome-libs-1.4.2-18.3.i586
    libxcb-xlib.so.0 is needed by gnome-libs-1.4.2-18.3.i586
    libxcb.so.1 is needed by gnome-libs-1.4.2-18.3.i586
    rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gnome-libs-1.4.2-18.3.i586

    If I download libdb-4.5.so,I do not know how to execute it.Still I am not able to find out for solution for rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by gnome-libs-1.4.2-18.3.i586
    Please assist me..Thanks in advance

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You can't install the needed packages in Yast? Since you use Enterprise version you should check with Novell since that is the commercial version.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3
    hai,thanks for your reply..After 48 hours I was able to successfully install OAS in my Suse Linux Enterprise Desktop..I followed many steps,the final step after seeing the log file which resolved my issue is follows..Pls check the following libraries and install if it is not available and try again

    gdbm-1.8.0-26.2.1
    gnome-libs-1.4.1.2.90-34.1

    Pls mail me for any issues


    Symptoms
    During the Configuration Assistant, the following error occurs in the OH/opmn/logs/HTTP_Server~1 log:

    /opt/app/oracle/product/http/ohs/bin/apachectl startssl: execing httpd
    /opt/app/oracle/product/http/ohs/bin/httpd: error while loading shared libraries: libgdbm.so.2: cannot open shared object file: No such file or directory


    Also the following opmnctl command fails with the same error in the ORACLE_HOME/Apache/Apache/logs/error_log:

    $OH/opmn/bin/opmnctl startproc process-type=HTTP_Server



    To solve the installation Configuration Assistant error, ensure the following RPMs are installed for both 32-bit and 64-bit OS:

    * gdbm-1.8.0-26.2.1 (i386 Or x86_64) based on the OS type.
    * gnome-libs-1.4.1.2.90-34.1 (i386 Or x86_64) based on the OS type.

    After that, the following error could appear in the same HTTP_Server~1 log
    /opt/app/oracle/product/http/ohs/bin/apachectl startssl: execing httpd
    /opt/app/oracle/product/http/ohs/bin/httpd: error while loading shared libraries: libdb-3.3.so: cannot open shared object file: No such file or directory

    To check these required packages have been installed, you can run the following command:
    # rpm -qa | grep gdbm-1.8

    Then finally link the older with the newer version.
    Only two days in Linux,I was able to succeed with help from you guys.
    Thank you so much for it....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •