Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have a SUSE 10 SP 2 server that needs to get added to a Windows Active Directory domain and registered in DNS. Samba is 3 0 28 - ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2010
    Posts
    7

    Question [SOLVED] Improperly Formed Account Name When Adding SUSE 10 to Windows Domain


    Hello,

    I have a SUSE 10 SP 2 server that needs to get added to a Windows Active
    Directory domain and registered in DNS. Samba is 3 0 28 - 0 5. I tried to join
    the domain with the following command:

    /usr/bin/net ads join -U MyDomainAdd%MyDomainPW

    The response is

    Failed to join domain: Improperly formed account name

    I tried to register in DNS with the following command:

    /usr/bin/net ads dns register -U MyDomainAdd% MyDomainPW

    There is no response of any kind, but the system does not get added in the
    Windows DNS.

    I previously enabled kerberos and can successfully do a kinit MyDomainAdd.
    After supplying the password, the klist command shows a valid ticket has
    been issued for the user MyDomainAdd.

    The clock is synchronized with the domain controller.

    Can anyone suggest what needs to be done to fix or further diagnose these
    problems? I'm a Linux newbie.

    (I tried including the contents of the krb5.conf and smb.conf files in this message, but the LinuxFourms.org interface gives the error "You are only allowed to post URLs to other sites after you have made 15 posts or more." This continued to happen even after I removed everything that looked like a URL to me!)

    Thanks in advance!

    Joseph

  2. #2
    Just Joined!
    Join Date
    Apr 2010
    Posts
    7

    Smile Problem Resolved

    In case anyone else runs into this issue: The problem was resolved by upgrading Samba. We were running 3.0.28-0.5, which is distributed with SLES 10 SP2. We upgraded to 3.0.36-0.5.5, which is available on the SLES 10 SP3 disc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •